ابحث في الدعم

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Can't use Netflix after installing Firefox 38. Still asking to install Silverlight?

  • 3 ردود
  • 66 have this problem
  • 3 views
  • آخر ردّ كتبه klown07

more options

I was under the impression we can now play Netflix videos without using Silverlight anymore, after the new update. did I not understand correctly? Netflix is still asking me to install Silverlight. i uninstalled it after reading about the changes.

I was under the impression we can now play Netflix videos without using Silverlight anymore, after the new update. did I not understand correctly? Netflix is still asking me to install Silverlight. i uninstalled it after reading about the changes.

الحل المُختار

Netflix still testing the Adobe DRM module and hasn't signed off on it yet, so Silverlight will be needed until Netflix allows that module plugin to be used.

http://www.engadget.com/2015/05/12/firefox-38/ See the comments at the bottom - the 3rd comment by Maverick.

Read this answer in context 👍 6

All Replies (3)

more options

Also, Firefox keeps telling my Adobe Shockwave Player is outdated. I've updated it twice, still get the same message :/

more options

الحل المُختار

Netflix still testing the Adobe DRM module and hasn't signed off on it yet, so Silverlight will be needed until Netflix allows that module plugin to be used.

http://www.engadget.com/2015/05/12/firefox-38/ See the comments at the bottom - the 3rd comment by Maverick.

more options

the-edmeister said

Netflix still testing the Adobe DRM module and hasn't signed off on it yet, so Silverlight will be needed until Netflix allows that module plugin to be used. http://www.engadget.com/2015/05/12/firefox-38/ See the comments at the bottom - the 3rd comment by Maverick.

Thank you, answered my question. Ah well, back to installing Silverlight! :)