Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Ctrl+Shift+T opens the wrong tab

  • 5 απαντήσεις
  • 3 έχουν αυτό το πρόβλημα
  • 128 προβολές
  • Τελευταία απάντηση από secretstaircase

more options

I'm not sure if this is an update or something I did, but the order of recently closed tabs has been reversed in my history. The newest one is now at the bottom of the list, so when I hit Ctrl+Shift+T to restore a closed tab, I get the tenth most recent tab I closed instead of the most recent one. Is there a way to fix this?

I'm not sure if this is an update or something I did, but the order of recently closed tabs has been reversed in my history. The newest one is now at the bottom of the list, so when I hit Ctrl+Shift+T to restore a closed tab, I get the tenth most recent tab I closed instead of the most recent one. Is there a way to fix this?

Επιλεγμένη λύση

I may not be qualified enough to help, so take everything I write here with some grain of salt ^^.

But one thing you could try is setting your saved closed tabs to 0 and back to 10 again. Maybe this resets the stack... To do so go to about:config and agree that you are careful, don't worry you are not changing anything dangerous. Then search for browser.sessionstore.max_tabs_undo and set it to 0 so no closed tabs are saved. Best you close Firefox and restart it, just to be safe. No go back to about:config and search for browser.sessionstore.max_tabs_undo if it doesn't open automatically. Set it back to 10.

Open some tabs and close them and see if it worked.

If this does not work, you could also set browser.sessionstore.max_tabs_undo to 1 so there is only 1 entry and therefore it is always at the top, however, this really is a very ugly workaround and I would not recommend this.


If this "soft reset" does not work I would assume that you have a junked up Firefox, as I have not found any setting that would allow you change the order in which closed tabs are stored or displayed.

Have you installed any addons recently? Did you already try resetting your Browser and Profile?

Ανάγνωση απάντησης σε πλαίσιο 👍 2

Όλες οι απαντήσεις (5)

more options

Επιλεγμένη λύση

I may not be qualified enough to help, so take everything I write here with some grain of salt ^^.

But one thing you could try is setting your saved closed tabs to 0 and back to 10 again. Maybe this resets the stack... To do so go to about:config and agree that you are careful, don't worry you are not changing anything dangerous. Then search for browser.sessionstore.max_tabs_undo and set it to 0 so no closed tabs are saved. Best you close Firefox and restart it, just to be safe. No go back to about:config and search for browser.sessionstore.max_tabs_undo if it doesn't open automatically. Set it back to 10.

Open some tabs and close them and see if it worked.

If this does not work, you could also set browser.sessionstore.max_tabs_undo to 1 so there is only 1 entry and therefore it is always at the top, however, this really is a very ugly workaround and I would not recommend this.


If this "soft reset" does not work I would assume that you have a junked up Firefox, as I have not found any setting that would allow you change the order in which closed tabs are stored or displayed.

Have you installed any addons recently? Did you already try resetting your Browser and Profile?

more options

Thanks, that first fix worked! I'm still not sure what went wrong, since I don't use many add-ons and haven't installed a new one for ages, but I'll bookmark this in case it happens again.

more options

Glad I could help :)

more options

Are you using Sync to sync open tabs to other devices?

more options

cor-el said

Are you using Sync to sync open tabs to other devices?

Nope, I only use Firefox on my desktop PC.