Αναζήτηση στην υποστήριξη

Προσοχή στις απάτες! Δεν θα σας ζητήσουμε ποτέ να καλέσετε ή να στείλετε μήνυμα σε κάποιον αριθμό τηλεφώνου ή να μοιραστείτε προσωπικά δεδομένα. Αναφέρετε τυχόν ύποπτη δραστηριότητα μέσω της επιλογής «Αναφορά κατάχρησης».

Learn More

Remember search and form history

  • 8 απαντήσεις
  • 0 έχουν αυτό το πρόβλημα
  • 25 προβολές
  • Τελευταία απάντηση από workshop3

more options

Remember search and form history. This setting always resets to false after the latest two FireFox updates and I need to enable it again.

After logging out and back in the setting is disabled again. I've removed all plugins and extensions I've added and the issue persists.

I've tried Places Database : Verify Integrity but the issue persists on very Restart or loggin. In the past I've even removed FireFox with a 3rd party uninstaller to remove all remnants of FF but, as a very long term user of FF (right from the early Win XP days), this issue pops up from time to time and it's really starting to become extremely annoying.

Apart from Refreshing FF or the total nuke and reinstall option, what else can be done to stop this issue?

Thanks.

Remember search and form history. This setting always resets to false after the latest two FireFox updates and I need to enable it again. After logging out and back in the setting is disabled again. I've removed all plugins and extensions I've added and the issue persists. I've tried Places Database : Verify Integrity but the issue persists on very Restart or loggin. In the past I've even removed FireFox with a 3rd party uninstaller to remove all remnants of FF but, as a very long term user of FF (right from the early Win XP days), this issue pops up from time to time and it's really starting to become extremely annoying. Apart from Refreshing FF or the total nuke and reinstall option, what else can be done to stop this issue? Thanks.

Επιλεγμένη λύση

I don't know why an update would change that setting to a non-default value. Strange.

But it only changes after updates? I ask that because there are two kind of files that could modify the value of the browser.formfill.enable preference from true to false, but they run at every Firefox startup (user.js and Autoconfig).

Which leads to an idea: you could create a user.js file in your profile folder to forcibly turn this feature on at every startup. If that holds, good news. If not, perhaps "something" is changing the value after startup.

(1) Locating your profile folder

Profiles - Where Firefox stores your bookmarks, passwords and other user data

(2) Set Windows to show all file extensions:

https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

(3) Creating a user.js file

This is a plain text file with a .js extension. If you double-click a .js file, Windows usually will execute it as system script, so avoid doing that. You can right-click > Edit when needed.

Place this command in the file:

user_pref("browser.formfill.enable", true);

Ref. http://kb.mozillazine.org/User.js_file

Ανάγνωση απάντησης σε πλαίσιο 👍 1

Όλες οι απαντήσεις (8)

more options

Still having this issue. Can anyone assist?

more options

Try entering about:policies in the address bar. If there is anything there, post it here.

more options

Note that Search and Form History is stored in formhistory.sqlite and not in places.sqlite (bookmarks and history).

more options

This support article may help. I wouldn't use Refresh. If you have to use it, backup your profile first.

https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

more options

Terry said

Try entering about:policies in the address bar. If there is anything there, post it here.

Cheers Terry,

Only see this: Active The Enterprise Policies service is inactive.

more options

Terry said

This support article may help. I wouldn't use Refresh. If you have to use it, backup your profile first. https://support.mozilla.org/en-US/kb/how-to-fix-preferences-wont-save https://support.mozilla.org/en-US/kb/back-and-restore-information-firefox-profiles

Tried all those however, I may have deleted a backup or two.

more options

Επιλεγμένη λύση

I don't know why an update would change that setting to a non-default value. Strange.

But it only changes after updates? I ask that because there are two kind of files that could modify the value of the browser.formfill.enable preference from true to false, but they run at every Firefox startup (user.js and Autoconfig).

Which leads to an idea: you could create a user.js file in your profile folder to forcibly turn this feature on at every startup. If that holds, good news. If not, perhaps "something" is changing the value after startup.

(1) Locating your profile folder

Profiles - Where Firefox stores your bookmarks, passwords and other user data

(2) Set Windows to show all file extensions:

https://www.bleepingcomputer.com/tutorials/how-to-show-file-extensions-in-windows/

(3) Creating a user.js file

This is a plain text file with a .js extension. If you double-click a .js file, Windows usually will execute it as system script, so avoid doing that. You can right-click > Edit when needed.

Place this command in the file:

user_pref("browser.formfill.enable", true);

Ref. http://kb.mozillazine.org/User.js_file

more options

Thank you jscher2000. Creating user.js and adding that code/command before using FF for anything else, well by George, so far it seems to have solved that pesky issue.