Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 29.0.1unable to view some webpages correctly

  • 2 replies
  • 1 has this problem
  • 15 views
  • Last reply by cor-el

more options

Ever since the latest update, many websites that were loading fine no longer display properly.

I can't even use my online banking anymore. The login buttons do not work anymore. All of these sites still work perfectly in IE.

Pages are formatted incorrectly, they have overlapping text, buttons, etc. Some controls are non-functional (maybe because where the button is displayed now and where it actually exists are now mismatched), and so on.

Even IMDB.com is completely borked. Sometimes reloading each page works, other times it doesn't.

Please help

Ever since the latest update, many websites that were loading fine no longer display properly. I can't even use my online banking anymore. The login buttons do not work anymore. All of these sites still work perfectly in IE. Pages are formatted incorrectly, they have overlapping text, buttons, etc. Some controls are non-functional (maybe because where the button is displayed now and where it actually exists are now mismatched), and so on. Even IMDB.com is completely borked. Sometimes reloading each page works, other times it doesn't. Please help

All Replies (2)

more options

Many site issues can be caused by corrupt cookies or cache. In order to try to fix these problems, the first step is to clear both cookies and the cache.

Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  • Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  • Under "Time range to clear", select "Everything".
  • Now, click the arrow next to Details to toggle the Details list active.
  • From the details list, check Cache and Cookies and uncheck everything else.
  • Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

more options

You may have zoomed the page(s) by accident.
Reset the page zoom on pages that cause problems.

  • View > Zoom > Reset (Ctrl/Command+0 (zero))

If you have made changes to Advanced font settings like increasing the minimum/default font size then try the default minimum setting "none" and the default font size 16 in case the current setting is causing problems.

  • Tools > Options > Content : Fonts & Colors > Advanced > Minimum Font Size (none)

Make sure that you allow pages to choose their own fonts.

  • Tools > Options > Content : Fonts & Colors > Advanced: [X] "Allow pages to choose their own fonts, instead of my selections above"

It is better not to increase the minimum font size, but to use an extension to set the default page zoom to prevent issues with text not being displayed properly.