Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Address autocomplete feature proposes old invalid addresses not even in Address Book

  • 6 replies
  • 7 have this problem
  • 1 view
  • Last reply by Zenos

more options

When I start writing a recipient's name in an email I'm composing, Firefox accesses an unknown database to propose several addresses I have used previously. These often include old addresses for my recipient that are no longer valid. In fact, more often than not these invalid addresses appear first, so if I just press Enter without thinking, that's where the message will be sent. Additionally, the proposed addresses often do not include addresses for the recipient that are in my Firefox Address Book. So it's a dual problem: I get bad addresses from some mysterious database, plus I don't get valid addresses from the Address Book. I need to know where this database that Firefox is accessing is located on my computer and how to edit it to remove all those invalid addresses I keep using inadvertently, and also how to get the autocomplete function to search the Address Book, which it is not doing. I should mention that in Tools - Options - Composition - Addressing, I have "Local Address Books" check-marked, and "Directory Server" is not checked. This is the only tool I've found in Firefox that seems to be related to this problem.

All Replies (6)

more options

They are in your Address Book.

Start a new message. Address it to one or more of these obsolete addresses. Save your message as a draft. View it in the Drafts folder, where the addressees will appear in the message's header. Here you can select, right-click and use Edit Contact to locate each of the entries in your Address Book.

Modified by Zenos

more options

Thank you for replying, Zenos, but I assure you I removed these obsolete addresses from the Address Book (including subdirectories I'd made in it). Hoping I was wrong, I anxiously tried your solution, but it doesn't seem to work. I'm not given an "Edit contact" option when I right-click on the address in a message I've put in the Drafts folder. The only options I'm given are "Add to Address Book..." (which is the opposite of what I want to do!), "Compose Mail To", "Copy Email Address", and "Create Filter from Message...". If I could actually do what you propose - access the actual record Firefox is using in the database and alter it - that would be perfect. I still believe it is accessing some other database, not Address Book. But thanks for trying to help!

more options

Are you using a Mac? if so, are these Contacts in the native OSX address book?

more options

Nope, Windows Vista (please don't go telling me how horrible it is; I didn't have a choice when I bought the computer!).

more options

I have the same exact problem and the email address that end up being entered "automatically" in my To: space when composing an email have quotation marks and slashes with spaces between characters. Ex: Mark ****** <" mark**"@ptd.net >

Where are these automatically chosen emails stored at? Is it a local folder, and where is it? Is it in the C: drive in a specific file for email configurations. I had the Personal Address folder and the Collected Address folders in my Address Book. I opened my address book one day and the Personal Address Folder was "GONE" and the Collected Address folder was there with emails that were unrecognizable, so I deleted it and figured I need to create a new Personal Address file and rebuild it. What a drag!!!! Which I have done with ALL emails having no erroneous characters, but still the automatic typing and insertion of these bogus email address shows up in the To: space. Ahhhhhhhhhhhh!!!!!!!! Please Help before my time on this planet expires :) I tried to make a new email and save the erroneous email to drafts. And was told to look for the yellow star and edit it and delete it. There was no yellow star next to the bogus email address, only mine. So that didn't work.

more options

But you're showing a message opened in the Compose window. You need to look at it as if you were reading it. Look at it in the Drafts folder. Don't open it for editing.

BTW, you have a "Print Screen" button on your keyboard. A lot less hassle to use than taking a photograph of the screen.

https://support.mozilla.org/en-US/kb/how-do-i-create-screenshot-my-problem

Modified by Zenos