Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

NetFlix change not compatible with FireFox is there a plug in?

  • 1 reply
  • 1 has this problem
  • 3 views
  • Last reply by agucova

more options

NetFlix recently updated their site. Until now I had no problem using it on FireFox, but now, all the little directional boxes ("next") show up as little squares with letters in them. (some other sites do the same thing) Also now NetFlix is requiring Silverlight be used. Didn't need it before. Any thing to be done? Or just have to live with it? I refuse to use IE. Thanks

NetFlix recently updated their site. Until now I had no problem using it on FireFox, but now, all the little directional boxes ("next") show up as little squares with letters in them. (some other sites do the same thing) Also now NetFlix is requiring Silverlight be used. Didn't need it before. Any thing to be done? Or just have to live with it? I refuse to use IE. Thanks

All Replies (1)

more options

feniangirl said

NetFlix recently updated their site. Until now I had no problem using it on FireFox, but now, all the little directional boxes ("next") show up as little squares with letters in them. (some other sites do the same thing) Also now NetFlix is requiring Silverlight be used. Didn't need it before. Any thing to be done? Or just have to live with it? I refuse to use IE. Thanks

Silverlight is needed for running Netflix, this has been needed always, the problem with the icons may be addon in firefox. So: Try Firefox Safe Mode to see if the problem goes away. Firefox Safe Mode is a troubleshooting mode that temporarily turns off hardware acceleration, resets some settings, and disables add-ons (extensions and themes).

If Firefox is open, you can restart in Firefox Safe Mode from the Help menu:

  • Click the menu button New Fx Menu, click Help Help-29 and select Restart with Add-ons Disabled.

If Firefox is not running, you can start Firefox in Safe Mode as follows:

  • On Windows: Hold the Shift key when you open the Firefox desktop or Start menu shortcut.
  • On Mac: Hold the option key while starting Firefox.
  • On Linux: Quit Firefox, go to your Terminal and run firefox -safe-mode
    (you may need to specify the Firefox installation path e.g. /usr/lib/firefox)

When the Firefox Safe Mode window appears, select "Start in Safe Mode".

SafeMode-Fx35

If the issue is not present in Firefox Safe Mode, your problem is probably caused by an extension, theme, or hardware acceleration. Please follow the steps in the Troubleshoot extensions, themes and hardware acceleration issues to solve common Firefox problems article to find the cause.

To exit Firefox Safe Mode, just close Firefox and wait a few seconds before opening Firefox for normal use again.