Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

IMAP account doesn't show subscribed subfolders

  • 8 replies
  • 8 have this problem
  • 771 views
  • Last reply by Festuco

more options

I've created a stucture of folders and subfolders on the server side of my IMAP email account. I'm able to subscribe to these folders in Thunderbird. However, I do only see one level of folders in my interface.

Example: Inbox\Games is shown, with the mails that are in there Inbox\Games\Steam is not shown, even though I subscribed to it.

Chosen solution

All folders are already checked for offline use.

But in the mean time, the folders have appeared. I can't figure out how/when it got fixed, but it is. Thanks all for your help.

Read this answer in context 👍 0

All Replies (8)

more options

Check with your email provider. Some providers do limit the number of hierarchy levels you can create.

more options

Thanks, I'll check with them. But since I created these subfolders through their interface, and they obviously publish their existence to Thunderbird since I can subscribe to them, I'd be surprised if this was the solution.

I just verified that these subfolders are available through my phone, so it isn't a limitation on the provider side.

Modified by Festuco

more options

Can you confirm that you have this setting: either via Menu Bar: 'View' > 'Folders' > 'All or via Mail toolbar: 'Menu icon' > 'Folders' > 'All'

more options

Yes, Folders All is selected.

more options

Please check settings here: Right Click on imap mail account name in the Folder Pane and select: 'Subscribe' click on the 'Refresh' button then click on OK

Did this get a bigger subscribe list?

If no, then check this info: Some email providers let you control which webmail folders are visible in a IMAP account. For example, Options -> Mail Settings -> Labels controls that in Gmail webmail. The gear like icon in the upper right corner is the Options list box. Check that any missing or empty folders are enabled, if your email provider has that feature.

Logon to your webmail account via a browser to see if there is a means of controlling folders for imap.

If still no, please tell us some info: Right Click on imap mail account name in the Folder Pane and select : 'Settings' Select: 'Server Settings' for the imap mail account Click on 'Advanced' button

Is this selected: 'Server supports folders that contain sub-folders and messages'

more options

I refreshed the subscribe list, and doublechecked the subscription for the folders in question, and they are subscribed.

I've seen the folders and their contents available in the email client on my phone, so they are being offered by my provider.

The Server supports folders etc... function is enabled.

Thanks for helping me get to the bottom of this, but we're not there yet, I'm afraid.

more options

Does it make any difference if you open Tools/Account Settings/accountname/Synchronization & Storage/Message Synchronization/Advanced and check the folders for offline use?

more options

Chosen Solution

All folders are already checked for offline use.

But in the mean time, the folders have appeared. I can't figure out how/when it got fixed, but it is. Thanks all for your help.