Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

There are colorized (colors change) bars along the left edge of my Firefox, and along the left edges of my Firefox' pull-down menus. How can I get rid of them?

  • 9 replies
  • 2 have this problem
  • 25 views
  • Last reply by Pop2029

more options

I'm using Debian 8; The Debian folk worked out their licensing issues with the Mozilla folk, and so my default browser was updated from Debian's Firefox-based browser to Firefox-ESR (Extended-Support Release). Iceweasel never had these flashing colored bars, and I find them very distracting. The colors change with user activity.

I'm using Debian 8; The Debian folk worked out their licensing issues with the Mozilla folk, and so my default browser was updated from Debian's Firefox-based browser to Firefox-ESR (Extended-Support Release). Iceweasel never had these flashing colored bars, and I find them very distracting. The colors change with user activity.

All Replies (9)

more options

Can you attach a screenshot?

  • use a compressed image type like PNG or JPG to save the screenshot
  • make sure you do not exceed the maximum size of 1 MB

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

  • Switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Appearance
  • Do NOT click the "Refresh Firefox" button on the Safe Mode start window
more options

I tried safe-mode, no avail. Also, I was already using the default theme, I switched out of safe-mode to double check. It's funny, even the warning box that popped up as I switched to safe-mode had the colored bar. The bar changes color with mouse movement over the browser and with browser activity (animations, Flash, etc.)

I uploaded a pair of screenshots showing the coloured bars.

more options

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh).

Is the problem still there?

more options

FredMcD said

Start Firefox in Safe Mode {web Link} by holding down the <Shift>
(Mac=Options)
key, and then starting Firefox. A small dialog should appear. Click Start In Safe Mode (not Refresh). Is the problem still there?

I tried safe mode, it did not help. I'm wondering if perhaps this is a Debian-specific problem...? Has anybody else seen this? What OS?

more options

Start your Computer in safe mode with networking. Then start Firefox. Try Safe websites. Is the problem still there?

<strike>[encyclopedia2.thefreedictionary .com/Linux+Safe+Mode Starting The Computer In Safe Mode;
Free Online Encyclopedia]
</strike>

Modified by James

more options

FredMcD this is Linux and not Windows as you use.

Pop2029 I wonder if this is due to the GTK theme you have in use whether GTK2 or GTK3 on Debian is not working right?

A possibility is perhaps the Nvidia driver?

I notice the extensions.gnome.org so what Gnome extensions do you have?

Could swear I have seen this similar thing posted about Firefox on Linux in past but it is a rare posting though. The Advanced search on this forum is not the most useful in finding such past posts though.

Modified by James

more options

Also you appear to be using Gnash in the versions appears to be the ancient Flash Player 10.1 branch and not at least 11.2 ESR.

Adobe now supports Linux proper again as of December 13 Release with 24.0.0.186 for Windows, Mac OSX and Linux.

https://get.adobe.com/flashplayer/ https://get.adobe.com/flashplayer/otherversions/ http://www.adobe.com/software/flash/about/

Modified by James

more options

James You've got me wondering whether it might be somehow related to GTK-3, although the bars are there with EVERY theme. If you look at the attached screenshot, you can see a colored bar alongside the popup from the editing dialog used to type this response... IDK about any Gnome extensions, as I don't use Gnome per-se. Using Debian, packages come pre-built for everyone, I suppose some Gnome extensions have been automatically installed along the way. I tend to avoid packages with Gnome or GTK-3 dependencies, preferring GTK-2 where possible. Perhaps that's why I've never encountered these colored bars before. I'm rather certain the bars are not Flash-related. I updated Flash anyway, though; thanks for the info.

I'm building FireFox from source right now, still v.45.6.0. I'll post the results.

more options

Pop2029 said

I'm building FireFox from source right now, still v.45.6.0. I'll post the results.

So, I built Firefox from source (Firefox-ESR -v45.6.0) and these colored bars persist. I tried passing the default build options to configure, and I tried adding --disable-faststripe, but it didn't matter -- both builds produced the same colored bars. IDK what to do to get rid of them!