Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

After an update, the page with recent sites no longer appears.

  • 1 reply
  • 1 has this problem
  • 1 view
  • Last reply by Happy112

more options

I am used to returning to frequently visited sites by 1) clicking on the + symbol and then 2) being taken to a page with icons representing those favorite sites. After a recent update, that facility vanished. Today, I was instructed to refresh Firefox to increase speeds; that favored site reappeared. Then I was instructed to install the latest version of Flash. Once again the page I want to keep disappeared. How can I get it back? Thanks,

I am used to returning to frequently visited sites by 1) clicking on the + symbol and then 2) being taken to a page with icons representing those favorite sites. After a recent update, that facility vanished. Today, I was instructed to refresh Firefox to increase speeds; that favored site reappeared. Then I was instructed to install the latest version of Flash. Once again the page I want to keep disappeared. How can I get it back? Thanks,

Chosen solution

Hi,

As the New Tab page reappeared after a Refresh, let's try Firefox in Safe Mode :

If Firefox is not running : Hold down the Shift key when starting Firefox.

If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Does that bring the New Tab page back again  ?

Read this answer in context 👍 0

All Replies (1)

more options

Chosen Solution

Hi,

As the New Tab page reappeared after a Refresh, let's try Firefox in Safe Mode :

If Firefox is not running : Hold down the Shift key when starting Firefox.

If Firefox is running : 3-bar menu => ' ? ' (at the bottom of the dropdown) => 'Restart with Add-ons disabled'. Then OK the restart. A small dialog should appear. Click 'Start in Safe Mode' ( not 'Refresh' !)

See : https://support.mozilla.org/en-US/kb/troubleshoot-firefox-issues-using-safe-mode

Does that bring the New Tab page back again  ?