Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Top Sites

  • 2 replies
  • 1 has this problem
  • 6 views
  • Last reply by McCoy

more options

In the recent Firefox update there is a new icon that pops up in my Top Sites with a magnifying glass icon on them. I love the Top Sites feature since it lets me quickly skip over to the sites I visit the most. But these new Icons with the magnifying glass on them only add the @website to the search bar instead of taking me to the site. How do I prevent these form appearing? I prefer that when I click on a site I got to it, instead of getting a "Search the site" option.

I've checked the options menu but all I can find are options on how to disable the Top Sites section entirely.

In the recent Firefox update there is a new icon that pops up in my Top Sites with a magnifying glass icon on them. I love the Top Sites feature since it lets me quickly skip over to the sites I visit the most. But these new Icons with the magnifying glass on them only add the @website to the search bar instead of taking me to the site. How do I prevent these form appearing? I prefer that when I click on a site I got to it, instead of getting a "Search the site" option. I've checked the options menu but all I can find are options on how to disable the Top Sites section entirely.

All Replies (2)

more options

I'm pretty sure you can remove them as follows:

When you hover your mouse over one of the "tiles" in Top Sites, a ••• button should appear in the circle near the top right corner of the tile. If you click that button, the drop-menu should provide you the option to "Dismiss" the tile. That will add it to a block list so it doesn't come back again.

Does that work on your new tab page?

See also: Customize items on your Firefox New Tab page

more options