Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

91.2.0 upgrade: FILE_CORRUPTED address book empty / can't send email

  • 8 replies
  • 2 have this problem
  • 27 views
  • Last reply by Lee

more options

I upgraded from 78.14 to 91.2.0 today. I am no longer able to Send email. My address book is also blank, but I continue to get auto-completion options when entering text into the "To" field. The error console displays the following when text is entered into the "To" field.

NS_ERROR_FILE_CORRUPTED: Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [mozIStorageService.openDatabase] SQLiteDirectory.jsm:43 NS_ERROR_FAILURE: 3 LDAPClient.jsm:255 [Exception... "Exception thrown by jsaddrbook://pab.na2: Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [mozIStorageService.openDatabase]" nsresult: "0x8052000b (NS_ERROR_FILE_CORRUPTED)" location: "JS frame :: resource:///modules/AbAutoCompleteSearch.jsm :: startSearch :: line 495" data: no] AbAutoCompleteSearch.jsm:495:13 NS_ERROR_FILE_CORRUPTED: Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [mozIStorageService.openDatabase] 2 SQLiteDirectory.jsm:43 NS_ERROR_FILE_CORRUPTED: Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [mozIStorageService.openDatabase] 2 SQLiteDirectory.jsm:43 Uncaught Exception { name: "NS_ERROR_FILE_CORRUPTED", message: "Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [mozIStorageService.openDatabase]", result: 2152857611, filename: "resource:///modules/SQLiteDirectory.jsm", lineNumber: 43, columnNumber: 0, data: null, stack: "openConnectionTo@resource:///modules/SQLiteDirectory.jsm:43:35\nget _dbConnection@resource:///modules/SQLiteDirectory.jsm:190:38\nget lists@resource:///modules/SQLiteDirectory.jsm:208:27\ngetMailListFromName@resource:///modules/AddrBookDirectory.jsm:375:22\nhasMailListWithName@resource:///modules/AddrBookDirectory.jsm:420:17\nmailListNameExists@resource:///modules/AddrBookManager.jsm:511:15\nupdateSendLock@chrome://messenger/content/messengercompose/MsgComposeCommands.js:5023:25\nupdateSendCommands@chrome://messenger/content/messengercompose/MsgComposeCommands.js:2040:3\nonRecipientsChanged@chrome://messenger/content/messengercompose/MsgComposeCommands.js:5745:21\nrecipientAddPills@chrome://messenger/content/messengercompose/addressingWidgetOverlay.js:964:5\nobserve@chrome://messenger/content/messengercompose/MsgComposeCommands.js:252:24\nhandleEnter@chrome://global/content/elements/autocomplete-input.js:584:31\nhandleKeyDown@chrome://global/content/elements/autocomplete-input.js:549:25\nAutocompleteInput/<@chrome://global/content/elements/autocomplete-input.js:40:54\n", location: XPCWrappedNative_NoHelper }

After an address and subject and content are entered, clicking the Send button has no effect, in the application or the error console. I've seen other posts about send and address book issues with 91.2, but their error messages are different from what I'm seeing. Thank you!

All Replies (8)

more options

Same problem. Updated from 78.14.0 to 91.2.0. Previously, when attempting to Forward a message, the Left column, which previously opened with a listing of recipients from my address book, no longer appeared. Therefore, i saw no listing from which to address my message. Furthermore, i could no longer locate any way to access my address book manually. Fortunately, I had previously made a full Macrium backup before updating so I have now reverted to my previous v. 78.14.0.

Helpful?

more options

Others are having this problem, but there are multiple separate posts, all unsolved. These are not the read-only issue:

91.2.0 upgrade: FILE_CORRUPTED address book empty / can't send email https://support.mozilla.org/en-US/questions/1354532

Address Book stopped working and can't send email on Thunderbird 91.2.0 after Update https://support.mozilla.org/en-US/questions/1353341

unable to send or forward email since updating to version 91.2 https://support.mozilla.org/en-US/questions/1354232

Upgrade to Thunderbird 91.2. Send and Receive do not work https://support.mozilla.org/en-US/questions/1354573 (content indicates Receive DOES work)

And possibly related: Cannot send mails in 91.2 https://support.mozilla.org/en-US/questions/1354574

Helpful?

more options

After updating to latest version 91.2.1, problem still exists.

Helpful?

more options

The articles I see regarding TB 91 seem to pertain to a new installation of Thunderbird. I don't see anything that addresses the update from v. 78 to 92.

Although I'm a long time user of Thunderbird, I'm not a techie so It's possible that some things may not be apparent to me although others have indicated problems as well when updating from a previous version.

Helpful?

more options

Mine was also an update from 78. All the posts I've seen on this, posted above, refer to updating or upgrading to 91.2.

Helpful?

more options

Based on my previous post, I deleted my existing TB 91.2.1 and did a complete full reinstall of the latest Thunderbird v. 91.2.1 from the Mozilla website.

Same problem: Can't send mail.

Helpful?

more options

I removed all traces of Ccleaner, Malware bytes, SpyBot S&D from the computer. I also set my Norton 360 to ignore SENT Mail. This effectively removed all virus detection that would affect Sent mail. I also verified that my Account Settings for sent mail were correct, up-to-date, and verified for Thunderbird. I also let Thunderbird 91.3 verify in Preferences as well. Nothing seems to make a difference. Still can't send email! Very frustrated since I was always able to keep up-to-date with the latest versions.

I'm back to 78.14.0 for now. I look forward for the gurus and programmers involved with TB to find a solution to my dilemma. It appears that several others have posted with the same problem.

PLEASE HELP!!!

Modified by James

Helpful?

more options

A solution has been posted here that worked for me and one other person: https://support.mozilla.org/en-US/questions/1352450?page=2#answer-1460230

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.