Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Cannot send emails. I get this when I try: An error occurred while sending mail: The mail server sent an incorrect greeting: "Cannot connect to SMTP server 64.59.128.135 (64.59.128.135:587) connect error 10060"

  • 24 replies
  • 1 has this problem
  • 103 views
  • Last reply by Newbeak

more options

Cannot send emails. I get this when I try: "An error occurred while sending mail: The mail server sent an incorrect greeting: "Cannot connect to SMTP server 64.59.128.135 (64.59.128.135:587) connect error 10060" Running Win7 I can receive emails okay.. Any suggestions would be appreciated.

All Replies (20)

more options

That is the server mail.shaw.ca. Do you have the correct settings?

mail.shaw.ca on port 587, STARTTLS security, authentication = normal password, User Name = part of address before @.

Helpful?

more options

Checked what you said to check,without luck.

Helpful?

more options

Error 10060 is a timeout error. What's the antivirus and its settings for email? In general, the TB profile folder should be added as an Exclusion in AV settings or Mail Shields and the like disabled. Do you have a VPN?

Helpful?

more options

I have Avast! free. I tried shutting down the Avast!,but that didn't work. I don't have a VPN.

Helpful?

more options
  • Restart Thunderbird with add-ons disabled (Thunderbird Safe Mode). On the Help menu, click on "Restart with Add-ons Disabled". If Thunderbird works like normal, there is an Add-on or Theme interfering with normal operations. You will need to re-enable add-ons one at a time until you locate the offender.
  • Restart the operating system in safe mode with Networking. This loads only the very basics needed to start your computer while enabling an Internet connection. Click on your operating system for instructions on how to start in safe mode: Windows 10, Windows 8, Windows 7, Windows Vista, Windows XP, OSX
If safe mode for the operating system fixes the issue, there's other software in your computer that's causing problems. Possibilities include but not limited to: AV scanning, virus/malware, background downloads such as program updates.

Helpful?

more options

Running TB in safe mode doesn't help-sending emails still times out.

Helpful?

more options

Newbeak said

Running TB in safe mode doesn't help-sending emails still times out.

The suggestion is to run Windows in safe mode, not TB, to test if Avast or other startup apps are blocking TB. Or, you can uninstall Avast and use an app like MS Security Essentials that is not known to interfere with TB.

Helpful?

more options

I was running windows in safe mode with networking when testing TB.

Helpful?

more options

I don't know if this still a factor, but you might have to change your password to a 'strong password' to access the account with a desktop mail app (not necessary for webmail or mobile mail apps):

https://support.shaw.ca/t5/internet-articles/how-to-choose-a-strong-password-for-your-shaw-accounts/ta-p/5277

Helpful?

more options

I have an 8 character p/w with upper and lower case letters,numbers and special characters,which I am sure is quite secure.

Helpful?

more options

I am wondering if reverting to an earlier version of TB would help? I am currently running version 91.2.1 (32-bit)

Helpful?

more options

I don't think using an earlier version would help, and doing so can cause more trouble than it's worth. I don't have any issues with that server in any version of TB.

Helpful?

more options

I royally screwed things up playing around with TB settings,so I did a system restore back to the 19th of Oct. I didn't go back far enough,so the problem is still there. Attaching an image of my Outgoing Server settings for what good that does.

Helpful?

more options

The server name in your picture is smtp.shaw.ca It must be mail.shaw.ca, as mentioned in my first reply (see picture).

Helpful?

more options

Thanks,you got my hopes up,but no luck. See attached. I think I have it right.

Helpful?

more options

Unless you have 2 Shaw accounts, there should only be one smtp server. You might have the account sending on the wrong smtp. Select an account in the left pane of Account Settings, then Outgoing Server (SMTP) in the right pane. Check that the account is sending on the correct smtp in the drop-down and click Edit SMTP Server... to view the settings. The User Name of the sending account must match the User Name of the smtp (assuming the smtp has the correct server settings).

Helpful?

more options

The only difference now is that the server settings for my acct has port 110 selected,and for the outgoing server,port 587 is selected. I assume they have to be different servers? I have removed the extra acct under outgoing server. I tried sending a test email,but it bombed again.

Helpful?

more options

Port 110 is the non-secure port for POP accounts. Use pop.shaw.ca on 995, SSL/TLS, authentication = normal password, User Name = part of address before @. The IMAP server is imap.shaw.ca on 993, other settings the same.

Helpful?

more options

Sorry,no dice. Got this error msg: 'Sending of the message failed. The message could not be sent because the connection to Outgoing server (SMTP) mail.shaw.ca timed out. Try again.''''

Helpful?

more options

Do you still have Avast installed? I would remove it. Also, reboot the modem/router for good measure.

Helpful?

  1. 1
  2. 2
Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.