Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

thunderbird oath2 incorrect path after I moved from Google to 365

  • 8 replies
  • 1 has this problem
  • 16 views
  • Last reply by ken144

more options

I have moved my email from the Gsuite to office365.

I have added a new email account to Thunderbird and I am receiving email fine.

However, my outgoing server (which should be smtp.office365.com with oath2) is repeatedly pointing me to the Google oath2 site for verification. I assume this must be a setting that is within Thunderbird that has not changed since. I have cleared all passwords repeatedly and removed cookies but am not having any luck.

Can anyone help?

All Replies (8)

more options

Is the gmail smtp still listed in Tools/Account Settings, Outgoing Server (SMTP) at the bottom of the left pane? Select the O365 account in the left pane of Account Settings, then note the Outgoing Server (SMTP) in the right pane: is it pointing to the O365 smtp? Also, check that all gsuite passwords or oauth tokens have been removed from Saved Passwords in Preferences.

Helpful?

more options

Hey sfhowes, thanks so much for taking the time. The SMTP settings are correctly pointing to O365 (and I have another 0365 account which works fine with similar settings). I think this is why I'm wondering if it's something saved over...

In terms of passwords and Oauth settings - I've removed all that pertain to this domain although there are some related to other domains which are also gmail - do you think I should remove these too?

Thanks again, K

Helpful?

more options

It wouldn't hurt to remove items from Saved Passwords, as the authentication is performed when TB restarts. That might force the correct OAuth window to open, for gmail and O265. If you enter oauth in the Config. editor search (in Preferences/General), it will show the URL for each account, so you might find the O365 account is linked to the gmail OAuth site.

Helpful?

more options

Thanks again. I removed all of those SMTP addresses within config but still the same issue I'm afraid. Any other ideas ?

Helpful?

more options

I've no idea why the sites are mixed up. See if the new accounts can be added correctly in a new profile, created in Help/More Troubleshooting, about:profiles.

Helpful?

more options

Thanks for the continued help.

I've removed all smtp settings for all accounts. Removed the account itself and reinstated it. i've removed all passwords.

It now is not prompting me for google, but is not prompting me for anything else either.

It's saying to verify the 'authentication method' in 'account settings | outgoing server (smtp)'. I'm not actually clear what this means.

If anyone knows, it would be great to know what should be against the issuer and scope in the config file. i've currently got.

issuer: login.microsoft.com scope: https://outlook.office365.com/IMAP.AccessAsUser.All https://outlook.office365.com/POP.AccessAsUser.All https://outlook.office365.com/SMTP.Send offline_access

do these make sense?

Helpful?

more options

Tools/Account Settings, Outgoing Server (SMTP) at the bottom of the left pane, check that the authentication method is OAuth2, as in this example.

Helpful?

more options

Ah right, yeh that's all set correctly. Thanks so much for your help with all this - it's been a total pain and I'm afraid I've pretty much just had it and decided to move to Outlook. I appreciate you trying to help me though, thank you.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.