Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google calendar reminders don't automatically display by default

  • 7 replies
  • 1 has this problem
  • 7 views
  • Last reply by cor-el

more options

When my Google calendar loads in Firefox the reminder entries don't display by default. All other calendar entries such as appointments, birthdays, etc. display just fine. To make the reminders display, I have to click on the calendar main menu (the three lines) and check the box next to reminders. Then the reminders display fine. However, the next time I start Firefox the reminders once again don't display. Once I have the reminders set I save the settings, but that doesn't help. I don't have this issue with Edge or Chrome. Has anyone else run into this, and if so, have they been able to fix it? Richard

When my Google calendar loads in Firefox the reminder entries don't display by default. All other calendar entries such as appointments, birthdays, etc. display just fine. To make the reminders display, I have to click on the calendar main menu (the three lines) and check the box next to reminders. Then the reminders display fine. However, the next time I start Firefox the reminders once again don't display. Once I have the reminders set I save the settings, but that doesn't help. I don't have this issue with Edge or Chrome. Has anyone else run into this, and if so, have they been able to fix it? Richard

All Replies (7)

more options

It would help if you show screenshots from Firefox and Chrome.

more options

Good idea jonzn4SUSE! I have attached two screen shots. One is Firefox where the reminder box is not checked on startup. The other Chrome where the box is checked on startup.

more options

It's checked for me. see screenshot

more options

I have two Windows 10 computers. The Google Reminders do not automatically display on either one. I have to click on the calendar main menu (the three lines) and check the box next to reminders. Then the reminders display fine. However, the next time I start Firefox the reminders once again don't display. Once I have the reminders set I save the settings, but that doesn't help. I don't have this issue with Edge or Chrome. Anyone have any ideas? Richard

more options

Have you checked your computer clock with the firefox internal clock to see they are in sync. That sounds more like clocks or timeline in each aren't match.

more options

I didn't know there was a firefox internal clock? Where do I find it? Richard

more options

You can use these steps to make a website recognize and remember you.

  • create a cookie allow exception with the proper protocol (https:// or http://) to make a website remember you

You can check that you aren't clearing important cookies.

  • using "Delete cookies and site data when Firefox is closed" keeps cookies with an allow exception
  • using "Clear history when Firefox closes" to clear cookies clears all cookies including cookies with an allow exception you may want to keep
  • clearing "Site Preferences" clears exceptions for cookies, images, pop-up windows, and software installation and exceptions for passwords and other website specific data
  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Exceptions"
  • Settings -> Privacy & Security
    Firefox will: "Use custom settings for history":
    [X] "Clear history when Firefox closes" -> Settings

Clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear