On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Declare a custom theme "light"

more options

As of recently, Firefox adapts some elements (basically everything in the toolbar, like the downloads or browsing history) depending on whether it identifies the theme you use as light or dark. I am using a custom theme (this one: https://addons.mozilla.org/de/firefox/addon/tardis/?utm_source=addons.mozilla.org&utm_medium=referral&utm_content=search) that Firefox identifies as dark, however I absolutely hate any form of dark mode. So far I figured out how to force Firefox to use a light theme everywhere else using about:config, but I couldn't figure out how to change the abovementioned elemtents back to light without changing the theme. So is there any way to declare a theme as light or some other way to change this behavior?

As of recently, Firefox adapts some elements (basically everything in the toolbar, like the downloads or browsing history) depending on whether it identifies the theme you use as light or dark. I am using a custom theme (this one: https://addons.mozilla.org/de/firefox/addon/tardis/?utm_source=addons.mozilla.org&utm_medium=referral&utm_content=search) that Firefox identifies as dark, however I absolutely hate any form of dark mode. So far I figured out how to force Firefox to use a light theme everywhere else using about:config, but I couldn't figure out how to change the abovementioned elemtents back to light without changing the theme. So is there any way to declare a theme as light or some other way to change this behavior?
Attached screenshots

Chosen solution

Hi there,

In this post: https://support.mozilla.org/en-US/questions/1360389?page=2#answer-1479952

Is a solution to lock Firefox to using a Light theme for all UI panels, even if opening a new window. The method uses AutoConfig which is a built-in way to control browser preferences.

I hope this helps.

-CB

Read this answer in context 👍 1

All Replies (9)

more options

Did you use this preference? layout.css.prefers-color-scheme.content-override

The options are Dark (0), light (1), system (2) or browser (3).

more options

TNorth said

Did you use this preference? layout.css.prefers-color-scheme.content-override The options are Dark (0), light (1), system (2) or browser (3).

I did, but the specific elements mentioned above remained dark (I just realized it also affects the window where you enter the master password as well as the window that pops up when you start a download). And before you ask, "ui.systemUsesDarkTheme = 0" also didn't help

Modified by frasiwa

more options

Evidently, Mozilla has decided that, if you use light text in your tabs, your theme is dark so you may have to change that part of your theme, if you can, or use a different theme. There is a detailed discussion here: https://support.mozilla.org/en-US/questions/1364418#answer-1474290

A userChrome.css file may be your best remedy if you are willing to go that far.

more options

Unfortunately I have absolutely no experience with .css files and can't be bothered learning it just to fix something like this. What the heck where they thinking forcing this on the users without the option to easily deactivate it?

more options

Chosen Solution

Hi there,

In this post: https://support.mozilla.org/en-US/questions/1360389?page=2#answer-1479952

Is a solution to lock Firefox to using a Light theme for all UI panels, even if opening a new window. The method uses AutoConfig which is a built-in way to control browser preferences.

I hope this helps.

-CB

Modified by Cyclone Boom

more options

Cyclone Boom said

Hi there, In this post: https://support.mozilla.org/en-US/questions/1360389?page=2#answer-1479952 Is a solution to lock Firefox to using a Light theme for all UI panels, even if opening a new window. The method uses AutoConfig which is a built-in way to control browser preferences. I hope this helps. -CB

You're a hero! With this you don't even need to make changes to "layout.css.prefers-color-scheme.content-override" and "ui.systemUsesDarkTheme".

Edit: I might have spoken a bit too soon. While the problem is mostly solved, I just realized the right-click context menus are still dark

Modified by frasiwa

more options

frasiwa said

You're a hero! With this you don't even need to make changes to "layout.css.prefers-color-scheme.content-override" and "ui.systemUsesDarkTheme".

Edit: I might have spoken a bit too soon. While the problem is mostly solved, I just realized the right-click context menus are still dark

Glad to hear it worked partially at least, but the context menus remaining dark isn't something I'd come across myself. I wonder whether this might be set at the operating system level possibly. I don't use Windows 10 here, but I've read how there are system themes. That seems likely to be controlling the context menus for what programs use. Of course, it depends whether setting to a Light theme for the OS would be desirable, since that would get globally applied.

It might be there's a way to exclude Firefox from this, or perhaps it requires another AutoConfig setting adding to force it similarly. Maybe if the ui.systemUsesDarkTheme needs setting to 0 so it tells it False for not using the dark system theme. I'm unable to verify or test this further on Windows 10 here however.

If so, the AutoConfig rule to add would be:

lockPref("ui.systemUsesDarkTheme", 0);

Then another possibility might be for a couple more rules as this answer explains.

Let us know if this might solve the context menus still being dark.

-CB

Modified by Cyclone Boom

more options

Cyclone Boom said

It might be there's a way to exclude Firefox from this, or perhaps it requires another AutoConfig setting adding to force it similarly. Maybe if the ui.systemUsesDarkTheme needs setting to 0 so it tells it False for not using the dark system theme. I'm unable to verify or test this further on Windows 10 here however.

Neither "us.systemUsesDarkTheme" nor any of the other about:config entries suggested in relation to this issue had any effect on that. However I found this simple way to fix this using userChrome.css

more options

frasiwa said

Neither "us.systemUsesDarkTheme" nor any of the other about:config entries suggested in relation to this issue had any effect on that. However I found this simple way to fix this using userChrome.css

Excellent, and great find there. I've added a note into my linked post (linking to yours) so hopefully it spreads awareness about this for anyone else with the same issue.