Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Web pages jumping down to email input box when reloaded....me no likey

  • 7 replies
  • 1 has this problem
  • 16 views
  • Last reply by Jack

more options

As of today, Feb 7th 2022, when I reload pages that have an email input box (to "sign up"), the page jumps down to where it can display that box as the last line displayed (which might be at the very bottom of the page). This happens on every page that has an email i/p box, but does not happen on any that do NOT have that box.

Furthermore, if that i/p box is about halfway down the page, and I have scrolled below it, then upon reloading the page it will scroll up so that the i/p box is the very first line displayed.

The i/p box is always filled with my email addy, and I don't mind if it is not (but I can't stop it from putting it in)

Restarting the browser did not change anything.

FWIW, I do not have caret browsing activated.

As of today, Feb 7th 2022, when I reload pages that have an email input box (to "sign up"), the page jumps down to where it can display that box as the last line displayed (which might be at the very bottom of the page). This happens on every page that has an email i/p box, but does not happen on any that do NOT have that box. Furthermore, if that i/p box is about halfway down the page, ''and I have scrolled below it'', then upon reloading the page it will scroll up so that the i/p box is the very first line displayed. The i/p box is always filled with my email addy, and I don't mind if it is not (but I can't stop it from putting it in) Restarting the browser did not change anything. FWIW, I do not have caret browsing activated.

Chosen solution

Disabling for the site works, but has an inherent problem (and this seems to be new). Just about every damn website wants me to subscribe or sign up these days, so most pages I open seem to have that box. Until yesterday I hadn't noticed this because there was no jumping to it.

The best solution for me is to delete the email address from the autofill extension altogether, and that obviates having to disallow it for pages that have a subscribe box.

It's very curious though, because it only started yesterday. There must have been an update to the extension or something.

Thanks for your assistance.

Read this answer in context 👍 0

All Replies (7)

more options

When you reload a page, the browser may take you to where the page was. Is this what is happening?

Helpful?

more options

Thanks for your response Fred. I wish that was the case - but no, if I am at the top of the page and reload...down it goes. If I go back a page which has an i/p box....down it goes.

Example: I'm at the top of the main page of a news site. I click on an article, read that page, and click back...it goes to the top (where I was, on the main page), and then straight down to the i/p box

Modified by brettinkat

Helpful?

more options

Not sure why, but my response is awaiting moderation after I edited a typo. In short, no, that is not the problem. If I'm at the top, reload, it goes down to the i/p box.

In the mean time, I just had a look at Autofill and the screenshot attached popped up to tell me what's new. The 4th line is interesting: Removed scrollintoviewifneeded() polyfill for Firefox

It looks more to me like it ADDED scrollintoviewifneeded()

Helpful?

more options

Sorry, current forum security sometimes delays the posting of messages.


I once had a similar issue with the web page jumping during loading. I finally traced the problem to a form filler add-on. I disabled the add-on for that site and the problem was gone.

Helpful?

more options

Chosen Solution

Disabling for the site works, but has an inherent problem (and this seems to be new). Just about every damn website wants me to subscribe or sign up these days, so most pages I open seem to have that box. Until yesterday I hadn't noticed this because there was no jumping to it.

The best solution for me is to delete the email address from the autofill extension altogether, and that obviates having to disallow it for pages that have a subscribe box.

It's very curious though, because it only started yesterday. There must have been an update to the extension or something.

Thanks for your assistance.

Helpful?

more options

You should contact that add-ons support and report the issue.

Helpful?

more options

I'm having this problem with Facebook, and it's really annoying. While I'm typing a comment, the page jumps down so the line I'm typing is at the very bottom of the page. I like to type at the middle of the page, so I move it up, and as soon as I hit a button, it jumps down again. Is the form fill extension the problem? I don't think I have one, but I'll check. Is there a setting I can change in Firefox Settings?

Thanks.

Edit: My only extensions are a VPN, and a video downloader. No form fill.

Modified by Jack

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.