Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Why are PDF documents downloading AND opening?

  • 3 replies
  • 3 have this problem
  • 37 views
  • Last reply by Terry

more options

Under my settings / applications, PDF files are listed twice as (application/force-download) AND (application/pdf). As a result, when I open a PDF file from within Firefox, the file opens AND downloads. I do NOT want it to download and ONLY want it to open. I have changed the setting to 'Always ask' and every other setting available, yet it continues to download AND open. How to I change it to OPEN only and NOT download?

Under my settings / applications, PDF files are listed twice as (application/force-download) AND (application/pdf). As a result, when I open a PDF file from within Firefox, the file opens AND downloads. I do NOT want it to download and ONLY want it to open. I have changed the setting to 'Always ask' and every other setting available, yet it continues to download AND open. How to I change it to OPEN only and NOT download?
Attached screenshots

All Replies (3)

more options

Changing the preference mentioned in the thread below may help but it's only a temporary fix. https://support.mozilla.org/en-US/questions/1370494

more options

I see the thread was closed without a solutuion. The CIRCUMVENTION being 'fiddling' about with 'config'. Just to re-state.... Since Firefox 98, PDF files that are OPENED within Firefox are also automatically (and INCORRECTLY) downloaded. If the PDF file is subsequently requested to be downloaded (using the 'button' within the PDF display/window), Firefox will either: Prompt stating that the file already exists; or (if the user picks his/her own filename) a 2nd copy of the file will be downloaded. Sorry to be direct but THIS IS A BUG THAT NEEDS FIXING.

more options

Evidently, the file is saved to your temp folder (as previously) if you select the option in Applications to Always Open in Firefox. I can't verify that because I have disabled Firefox as a pdf viewer but I have seen it mentioned by several users.