Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How, or can, I stop the download manager from opening up automatically?

  • 16 replies
  • 5 have this problem
  • 2646 views
  • Last reply by rokkzul

more options

I'm a little surprised they've taken away the option of choice when it comes to downloading files. But what's most annoying, is the manager opens u and drops down blocking my view of the page, much less that it makes ms stop and think about what I am about to download.

I do not understand the purpose of this. The old way was safer, cleaner and less annoying. How can, or am I able to get that "choice" back?

When searching for a fix I have seen that that there is/was a similar feature in the Edge browser but it can be undone. I feel Firefox users deserve that option.

Thank you.

Thank you.

I'm a little surprised they've taken away the option of choice when it comes to downloading files. But what's most annoying, is the manager opens u and drops down blocking my view of the page, much less that it makes ms stop and think about what I am about to download. I do not understand the purpose of this. The old way was safer, cleaner and less annoying. How can, or am I able to get that "choice" back? When searching for a fix I have seen that that there is/was a similar feature in the Edge browser but it can be undone. I feel Firefox users deserve that option. Thank you. Thank you.

Chosen solution

In Firefox 97 and 98+ there have been changes to the download panel.

You can set this pref to false on the about:config page to prevent opening the download panel on each download.

  • browser.download.alwaysOpenPanel = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

Read this answer in context 👍 1

All Replies (16)

more options

Chosen Solution

In Firefox 97 and 98+ there have been changes to the download panel.

You can set this pref to false on the about:config page to prevent opening the download panel on each download.

  • browser.download.alwaysOpenPanel = false

You can open the about:config page via the location/address bar. You can accept the warning and click "I accept the risk!" to continue.

more options

Enter about:config in the URL bar and set browser.download.alwaysOpenPanel = false.

WARNING: Changing preferences through this interface not officially supported Hidden settings edited using the about:config tool are explicitly not supported, which means that Mozilla makes no guarantees they will be supported in the future, or that Mozilla will fix them if they break. Mozilla does not test these preferences, and will not in the future. That includes security and performance testing which these preferences may affect.

[Warning added by moderator]

more options

Thank you sirs!

more options

I still have the problem with FF 100 on Linux Mint 20.3

more options

Le-Bilboquet said

I still have the problem with FF 100 on Linux Mint 20.3

Which problem -- the problem that the downloads list drops automatically from the toolbar after every download, or a different download-related problem?

Currently, the workaround earlier in the thread is the only workaround for the downloads list opening automatically after every download. It would work the same on Linux/Mac/Windows.

more options

Yes downloads list drops automatically even when the parameter sys not to open

and with some files when the URL link does not begin with HTTP

Wow can I downgrade to FF 99 ? Thank you

more options

Le-Bilboquet said

Yes downloads list drops automatically even when the parameter sys not to open and with some files when the URL link does not begin with HTTP

That's strange. Using just the built-in features, that should require a click on the button. Maybe an add-on is opening it somehow? Or maybe it opens for actions that happen in the background, that you didn't trigger yourself??

Regarding other protocols, it's normal to get one or two prompts: a site permission prompt and a "which program should I use" prompt. But these shouldn't show up as downloads at all.

more options

I found the culprit

PDF files are set to be opened by default.

But there is still a problem with links that do notm begin with HTTP.


For example, on pages https://support.hp.com/ca-fr/product/hp-probook-455-g8-notebook-pc/38228735/manuals and https://support.hp.com/ca-en/product/hp-probook-455-g8-notebook-pc/38228735/manuals you will see that some manuals will download 0 bytes files and obviously thay their links do not begin with http.

more options

Oh, I think I know what you're talking about. I have PDFs set to "Open in Firefox" so I don't see the problem with PDFs, but I have seen it with DOC files. Let's see whether it's the same issue:

This is a "mixed content blocking" feature related to HTTP:// links in HTTPS:// pages. If the links use HTTPS:// there isn't a problem, but if they use HTTP://, Firefox halts the download after creating a 0-byte placeholder and shows an error/warning panel:

I discovered that issue in Firefox 99, so rolling back to Firefox 99 won't help with that one.

There is a bug on file to remove that 0-byte file, but it's not high priority so for now, we need to click through and choose whether to remove the 0KB file or download the full file.

more options

jscher200 you say FF hows an error/warning panel:

But I don't get that panel with "File Not Downloaded .Potential Security Risk" message.

It just records that 0 bytes file and says nothing.

more options

I have a question: how do I unsubscibe from a thread that was resoloved, particulaly--this one! I keep getting damn emails about this, that I posted, when it was resolved, literally, the same day I posted it. Can someone lock this thing down because it's getting very annoying or perhaps I should flag it as abuse.

Thank you.

more options

springheel said

I have a question: how do I unsubscibe from a thread that was resoloved, particulaly--this one! I keep getting damn emails about this, that I posted, when it was resolved, literally, the same day I posted it. Can someone lock this thing down because it's getting very annoying or perhaps I should flag it as abuse. Thank you.


Hi

At the bottom of the email the text says :

This email is automatically sent by a robot. Our robot can’t respond to your question, but our forum contributors can! If you want to respond to them, please click here.


I hope this solve the matter for you sir.

more options

springheel said

I have a question: how do I unsubscibe from a thread that was resoloved, particulaly--this one!

On the upper right of the page under Question Tools there are links to subscribe/unsubscribe to email updates for the thread.

more options

Le-Bilboquet said

But I don't get that panel with "File Not Downloaded .Potential Security Risk" message. It just records that 0 bytes file and says nothing.

Okay, since the question changed from the panel opening to 0 byte files appearing, please start a new question for that problem:

https://support.mozilla.org/questions/new/desktop/form

more options

Just did. thanks for the cudo

more options

I was having this problem (currently on version 101) and doing the steps didn't solve it from me. However i seemed to fix it by clicking the file while it was being downloaded and it stopped the underline message of "File is going to be opened in...". Hope it helps someone.