Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Thunderbird

  • 4 replies
  • 1 has this problem
  • 17 views
  • Last reply by Toad-Hall

more options

I can't for the life of me find out how to stop Thunderbird from deleting my emails form Thunderbird and my email server. I use to think it was after 30 days but my oldest email is from May 11th, today is the 26th. So maybe it's a set size limit. My email is through my web hosting provider and it is set to unlimited. When I asked them they said there's a setting on an email client that is deleting my emails. How do I fix this? I have tried to delete the email account and add it again from scratch but that didn't do anything. Many times I need to access older emails from my customers that are just gone.

I know another person mentioned this before but I didn't see a resolved answer, only that he created a new folder to import his old messages to. Which I don't see how to do that but also feel that's just a band-aid type fix. I want my emails to stop being deleted automatically, only if I delete them.

I can't for the life of me find out how to stop Thunderbird from deleting my emails form Thunderbird and my email server. I use to think it was after 30 days but my oldest email is from May 11th, today is the 26th. So maybe it's a set size limit. My email is through my web hosting provider and it is set to unlimited. When I asked them they said there's a setting on an email client that is deleting my emails. How do I fix this? I have tried to delete the email account and add it again from scratch but that didn't do anything. Many times I need to access older emails from my customers that are just gone. I know another person mentioned this before but I didn't see a resolved answer, only that he created a new folder to import his old messages to. Which I don't see how to do that but also feel that's just a band-aid type fix. I want my emails to stop being deleted automatically, only if I delete them.
Attached screenshots

All Replies (4)

more options

check your setting at tools>accountsettings>account>synchronization&storage

Helpful?

more options

This isn't the issue. I have it set to not delete any messages. I thought it might have been my phone's email app but I have tried others and the emails still keep getting deleted. It's not my host setting since I have it set to unlimited as well. To help any else looking for this, the synchronization & storage is actually under the Edit>Account Settings menu.

Modified by Hopeinformer

Helpful?

more options

re : I thought it might have been my phone's email app

The most common reason for losing emails in Thunderbird imap account is because the user is also using either another computer and/or email client or phone and they are not set up as imap.

If that phone app is set up as pop then it needs to also be set up to 'Leave message on server' or else the server will delete the copy of popped email. This means when you start Thunderbird, it will ony show what is on server.

All devices connecting to the webmail/server account need to be set up as imap.

If in the past you have used another email client eg: Outlook etc, then please double check to see if they are still running in the background. I have known people discover they had Outlook set up with a pop mail account with no setting to Leave on server. They were no longer using Outlook, but unbeknown to them, it was still running in the background and downloading mail. As it was a pop account, the server auto deleted all popped emails. Hence nothing on server so imap account could not show what did not exist.

Many servers do auto empty Trash and Spam folders. So emails being removed from those folders would be a different issue.

Modified by Toad-Hall

Helpful?

more options

re :To help any else looking for this, the synchronization & storage is actually under the Edit>Account Settings menu.


You would need to post an image showing 'Edit' menu containing 'Account Settings'. I've never heard of this.

Any of the following methods will open the 'Account Settings' tab - images below.

  1. 'Mail Toolbar' toolbar - 'Menu app icon' (3 lines) > 'Account Settings'
  2. 'Menu Bar' toolbar - 'Tools' > 'Account Settings'
  3. Select account name in Folder Pane - top right click on 'Account Settings'
  4. Right click on mail account name in Folder Pane and select 'Settings'

The Account Settings will list all mail accounts in left pane. Each mail account has various sub menu options which when selected display relevant contents in the right pane. Only Imap mail accounts will have 'Synchronisation & Storage'. example images below as guide

Modified by Toad-Hall

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.