On Aug 14th 11 PM ET/Aug 15th 03:00 UTC, due to scheduled Firefox Account server maintenance, users may not be able to sign in or create a new subscription. This is expected to last approximately 30 minutes. Status updates can be found at https://status.vpn.mozilla.org or https://status.relay.firefox.com.

Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox Disable spell checking

  • 2 replies
  • 1 has this problem
  • 6 views
  • Last reply by sweet0670

more options

You can't disable firefox spell checking. Check your spelling as you type. Misconfiguration? Did you make a mistake somewhere? I'm not sure. I mainly use two types of IME, Microsoft IME and google Japanese input.

You can't disable firefox spell checking. Check your spelling as you type. Misconfiguration? Did you make a mistake somewhere? I'm not sure. I mainly use two types of IME, Microsoft IME and google Japanese input.
Attached screenshots

Chosen solution

Firefox normally wouldn't do a spell check for single line input fields (layout.spellcheckDefault = 1), so it wouldn't work with this Google page.

I notice that you have a lot of extensions installed including "Checker Plus for Gmail".

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window
Read this answer in context 👍 1

All Replies (2)

more options

Chosen Solution

Firefox normally wouldn't do a spell check for single line input fields (layout.spellcheckDefault = 1), so it wouldn't work with this Google page.

I notice that you have a lot of extensions installed including "Checker Plus for Gmail".

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Helpful?

more options

Thank you. If you follow the advice, you won't see the red spell check line for now. It seems that "Checker Plus for Gmail" and "userChrome.css" were the cause. After disabling these two, it disappeared. I want to use it as it is for a while and see how it looks. Thanks to you, I was refreshed. Thank you.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.