Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Default behaviour of searching in address bar

  • 6 replies
  • 0 have this problem
  • 16 views
  • Last reply by cor-el

more options

Hello, I just built a new PC and have a fresh install of Firefox.

As seen in the image, the default 'search' that I type into the address bar is trying to go to a webpage (the web/globe icon) I would like it to default to search, (like the magnifying glass icon), rather than having to press the down arrow to get to it.

I had this functionality on the old computer. Curious how to get it back. Thank you.

Hello, I just built a new PC and have a fresh install of Firefox. As seen in the image, the default 'search' that I type into the address bar is trying to go to a webpage (the web/globe icon) I would like it to default to search, (like the magnifying glass icon), rather than having to press the down arrow to get to it. I had this functionality on the old computer. Curious how to get it back. Thank you.
Attached screenshots

All Replies (6)

more options

You can possibly disable some types of suggestions. The location bar drop-down list can show history items, bookmarked pages, pages opened in tabs, top sites, and search suggestions. You can set what suggestions show when you enter an URL in the location/address bar bar.

  • Settings -> Privacy & Security
    Address Bar: When using the location bar, suggest:
    History
    Bookmarks
    Open tabs
    Top sites
    Shortcuts
    Search Suggestions

See also this pref on the about:config page.

  • about:config => browser.urlbar.showSearchSuggestionsFirst

You can open the about:config page via the location/address bar. If you get the warning page, you can click the "Accept the Risk and Continue" button.

Modified by cor-el

Helpful?

more options

Thank you cor-el for the advice, unfortunately that doesn't seem to solve it.

I found a simpler way to describe the issue: When I type and press enter in the address bar, I would like it to default to Google searching, rather than it trying to add the http at the beginning and treating my search like a URL.

Helpful?

more options

You can optionally add the separate search bar to the Navigation Toolbar or the chevron overflow area if you want to force a search.

Helpful?

more options

Helpful?

more options

Thanks again for the input, unfortunately still no go on a solution. I've attached another screenshot.

When I type into the address bar it's automatically trying to make that text into a URL, as noted in the screenshot with the http and the / at the beginning and end of my 'searchsuggestion' text.

Previously (before the new computer build) I was able to enter text and by default it was a Google search when I hit enter. If I were to finish a URL (example: searchsuggestion.com) then it would load the website. That's the functionality I'm trying to bring back.

Google is the default search engine in the settings, but every time I type it's trying to create a web address. If I type a string of words with spaces (example 'search suggestion') then I'm met with a 'Hmm something isn't right' page. It's one of those little things that's got to be in a setting somewhere, just can't seem to find it.

Modified by BrianFirefoxUser

Helpful?

more options

You can append a '?' to force a search There are prefs like these on the about:config page you can look at.

  • browser.fixup.dns_first_for_single_words
  • browser.urlbar.dnsResolveSingleWordsAfterSearch [0:never resolve;1:use heuristics(*);2:always resolve]

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.