Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Facebook posts jumping around

  • 2 replies
  • 0 have this problem
  • 9 views
  • Last reply by cor-el

more options

I am having a problem with Firefox when using Facebook. After scrolling down and viewing posts the posts start to jump around. You need to scroll down viewing many posts before this starts. It is very annoying. Once it starts it will jump around without any operator intervention. I have tried troubleshoot mode and also reset to no avail. This happens on two different systems in different locations both using Linux Mint 20.03 and the latest Firefox 102.0.1 64 bit. It also did this on prior versions and seems to have started as long as 6 months ago. I have mostly ignored it as reloading the FB page stops the insanity. I would say this is a FB problem but running FB with Chromium on these systems under the same conditions results in no problem.

Hopefully I am not the only one experiencing this and you will find the problem until then I am forced to use Chromium to view FB.

I am having a problem with Firefox when using Facebook. After scrolling down and viewing posts the posts start to jump around. You need to scroll down viewing many posts before this starts. It is very annoying. Once it starts it will jump around without any operator intervention. I have tried troubleshoot mode and also reset to no avail. This happens on two different systems in different locations both using Linux Mint 20.03 and the latest Firefox 102.0.1 64 bit. It also did this on prior versions and seems to have started as long as 6 months ago. I have mostly ignored it as reloading the FB page stops the insanity. I would say this is a FB problem but running FB with Chromium on these systems under the same conditions results in no problem. Hopefully I am not the only one experiencing this and you will find the problem until then I am forced to use Chromium to view FB.

All Replies (2)

more options

You are not alone, there is a thread here: https://support.mozilla.org/questions/1382198

Do you scroll by clicking and dragging down on the "thumb" on the scroll bar? Try instead clicking in the blank space below the thumb (should advance by one screen-height) to see whether that avoids the problem.

Helpful?

more options

You can try Firefox from the official Mozilla server if you currently use a version from the repositories of your Linux distribution to see if it behaves differently.


If you use extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) that can block content (Adblock Plus, NoScript, DuckDuckGo PE, Disconnect, Ghostery, Privacy Badger, uBlock Origin) always make sure such extensions do not block content.

Firefox shows a purple shield instead of a gray shield at the left end of the location/address bar in case Enhanced Tracking Protection is blocking content.

  • click the shield icon for more detail and possibly disable the protection

You can check the Web Console for relevant-looking messages about blocked content.


You can try these steps in case of issues with webpages:

You can reload webpage(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

clear the Cache and remove the Cookies for websites that cause problems via the "3-bar" Firefox menu button (Settings).

"Remove the Cookies" for websites that cause problems:

  • Settings -> Privacy & Security
    Cookies and Site Data: "Manage Data"

"Clear the Cache":

  • Settings -> Privacy & Security
    Cookies and Site Data -> Clear Data -> [X] Cached Web Content -> Clear

Start Firefox in Troubleshoot Mode to check if one of the extensions ("3-bar" menu button or Tools -> Add-ons -> Extensions) or if hardware acceleration or userChrome.css is causing the problem.

  • switch to the DEFAULT theme: "3-bar" menu button or Tools -> Add-ons -> Themes
  • do NOT click the "Refresh Firefox" button on the Troubleshoot Mode start window

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.