Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Firefox 103.0 causing graphical glitches

  • 5 replies
  • 0 have this problem
  • 8 views
  • Last reply by ghostshadow

more options

Hello,

Firefox just updated a little while ago to 103.0. Since then, anytime Firefox is open and I either scroll or hover over menu options it causes graphical glitches. I've included an image I was able to print-screen.

It doesn't occur with other browsers. Suggestions?

I'll add that Firefox seems to also be freezing up as well.

Hello, Firefox just updated a little while ago to 103.0. Since then, anytime Firefox is open and I either scroll or hover over menu options it causes graphical glitches. I've included an image I was able to print-screen. It doesn't occur with other browsers. Suggestions? I'll add that Firefox seems to also be freezing up as well.
Attached screenshots

All Replies (5)

more options

Did you turn off hardware acceleration.

Helpful?

more options

Didn't change any settings. Hardware Acceleration is set to 'on' under the "Use recommended performance settings" option.

Helpful?

more options

Can you provide steps to replicate the issue?

Helpful?

more options

Firefox automatically updated, I was scrolling Twitter when the graphical issues appeared. I didn't do anything beyond that. Nothing else was updating, no settings were changed, nothing was being scanned, installed, or changed in anyway.

Since my last comment, I did a computer restart and I haven't yet noticed any more graphical glitches. So I guess I can consider it resolved for now.

Helpful?

more options

I am also experiencing a similar issue but when embedded YouTube videos play or if they play in a private tab. Not having the issue when directly on YouTube though.

The screen will break up into 3 sections and the image is mirrored between those 3 sections. It will go back to normal if I scroll up but if I go back down to the video or beyond where the video is embedded, it will glitch again.

I tried to take a screenshot but it only produced a normal image so I took a photo of my physical screen. I haven't had this issue up until the latest update. Nothing else on the computer has been changed, no new extensions or anything.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.