Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Blocked from graphics hardware

  • 13 replies
  • 4 have this problem
  • 59 views
  • Last reply by 1musky

more options

I just started getting this - firefox.exe has been blocked form accessing graphics hardware. I'm running FF version 103.0.1 Win 10


Thanks

I just started getting this - firefox.exe has been blocked form accessing graphics hardware. I'm running FF version 103.0.1 Win 10 Thanks

All Replies (14)

more options

Can you post a screenshot of this issue? Can you provide steps to replicate? What security software are you running?

Helpful?

more options

It appears in my notifications. sometimes when I start my computer. Sometimes when i open the browser. sometimes when I try to go to a page that ff can no longer open. I am running the standard win 10 security package. I haven't changed the settings on anything. Pretty much any page that has streaming video.

Helpful?

more options

Is it Intel GPU?

Helpful?

more options

I manually ran a windows update check and it installed the latest version on win 10. Don't know why but everything is fine now.

Helpful?

more options

Helpful?

more options

It went bad again right away. I went in and checked through all my settings. This last FF update for some reason changed one setting. It turned on the hardware acceleration. Turned that back off and everything has been fine since. Thanks for the help.

Helpful?

more options

The specs would be nice. Is this a desktop or laptop and what model? Looks like updates are needed.

Modified by jonzn4SUSE

Helpful?

more options

You shouldn't turn off that setting.

Helpful?

more options

1musky said

I just started getting this - firefox.exe has been blocked form accessing graphics hardware. I'm running FF version 103.0.1 Win 10 Thanks

Same problem here.

Windows 10 64 bit Pro Firefox 103, FF 103.01

Hardware : HP Pavilion G6 laptop. Core i3 CPU, 4gb ram, Intel integrated GPU.

Have tried all suggested fixes including a registry hack, for God's sake. Nothing fixes it.

Purge FF & reinstalled from fresh FF 103.01 installer. No difference.

Other browsers on same machine: Edge - no issue. Brave - no issue.

Helpful?

more options

1musky said

It went bad again right away. I went in and checked through all my settings. This last FF update for some reason changed one setting. It turned on the hardware acceleration. Turned that back off and everything has been fine since. Thanks for the help.

Turning off hardware acceleration is inadvisable as it makes FF run a lot slower. It is not necessary in any other browser on my laptop so clearly something is broken in FF 103/103.01

Helpful?

more options

I can have a semi functional faster FF or a fully functional slower FF. I'll choose slower and functional and leave the acceleration off. I agree this version of FF is broken.

Helpful?

more options

I have been having this issue as well since the last Firefox update. Never happened before that.

Helpful?

more options

Update to 103.0.2 did nothing to fix this.

Helpful?

more options

I have this problem too, same as this:

[[Knowledge Base Article|https://support.mozilla.org/en-US/questions/1324979]]

Ran DISM and sfc, no problems. Everything is up to date. CPU:Intel(R) Core(TM) i7-2620M GPU:520m 1TB SSD 8GB RAM

I go to sites like: https://www.ign.com/articles/last-of-us-tv-hbo-henry-sam-casting And it starts with Windows hanging, then the browser goes all blank, if I'm High Performance mode it eventually manages to go back to normal and loads the page, but it goes blank again if I scroll up, if I'm in "Normal" mode, not power saving nor high performance, it takes longer to get to normal and may cause Windows to block the Graphic Hardware access.

If I go to: https://www.asus.com/it/Networking-IoT-Servers/WiFi-Routers/ASUS-Gaming-Routers/RT-AX86U/ The page loads easily, but if I scroll down and then up, when I scroll all the way up it does the same stuff. Windows hanging, browser goes full blank, after a little while it loads the page and goes back to normal, but if it fails to do so, Windows blocks it from accessing the graphics hardware.

What is even weirder is the fact that running the Troubleshoot Mode does not present the problem, loads both pages fine, scroll up, scroll down, no problem whatsoever, but refreshing the profile does not solve it. No extensions, no themes, no configurations, no nothing, straight up new profile out of the box, still gets the problem.

Edit. Some more context: I have an Asus U36SD Laptop Windows 10 Pro 64 Bit No other antivirus apart from Windows Defender FF 103.0.2 (Problem already present at least in 103.0.1 and maybe 103.0 I don't recall when it started but it's pretty recent)

Modified by vise-pingu

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.