Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google Calendar and Other Sites Not Rendering Correctly

  • 5 replies
  • 0 have this problem
  • 59 views
  • Last reply by Brian B.

more options

Google Calendar and a few other websites do not render symbols correctly. Please see attached. What should be displayed instead of letters are symbols such as > or ^. I've tried updating FF (103.0.2), ran in Safe Mode, disabled extensions, and nothing has helped. I'd like to keep using FF instead of Safari (running MacOS Monterey 12.5.1), but this is annoying.

Any ideas?

Google Calendar and a few other websites do not render symbols correctly. Please see attached. What should be displayed instead of letters are symbols such as > or ^. I've tried updating FF (103.0.2), ran in Safe Mode, disabled extensions, and nothing has helped. I'd like to keep using FF instead of Safari (running MacOS Monterey 12.5.1), but this is annoying. Any ideas?
Attached screenshots

Chosen solution

All Replies (5)

more options

Chosen Solution

Helpful?

more options

Hi Brian, was it the "Allow pages to choose their own fonts" or an add-on blocking remote fonts?

I guess either way, you can mark your reply as the solution to close out this thread.

Helpful?

more options

It was the "Allow pages to choose their own fonts." I had manually tried a different font (on the right path) but that didn't work.

Helpful?

more options

Note that these days a lot of websites use an iconic font to display small images. If you disable website font via "Allow pages to choose their own fonts, instead of my selections above" then such fonts are disabled and you may see little boxes with the hex code of the character or text labels instead.

Helpful?

more options

@cor-el I haven't noticed any issues yet, but that's good to know. It was primarily G calendar and one other site that I noticed the problem on. But as mentioned, when I manually tried a different font, it still didn't work and I was about to give up.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.