Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How do I lock bookmarks on the bookmark tool bar?

more options

I'm a gamer and alt+tab considerably often. Most of the time I end up on FireFox because I need to look at a map or browse reddit while I'm in queue. However, whenever I alt+tab frequently a bookmark will get selected as if I am clicking and dragging. The bookmarks on the bookmark tool bar always end up in different places. Is there a way to lock these links in place so I can't move them or do I have to resign myself to fixing it every day?

I'm a gamer and alt+tab considerably often. Most of the time I end up on FireFox because I need to look at a map or browse reddit while I'm in queue. However, whenever I alt+tab frequently a bookmark will get selected as if I am clicking and dragging. The bookmarks on the bookmark tool bar always end up in different places. Is there a way to lock these links in place so I can't move them or do I have to resign myself to fixing it every day?

Chosen solution

jscher2000 - Support Volunteer said

Possibly Windows missed the Alt because it is possible to tab from the address bar to the first bookmark on the Bookmarks Toolbar. To disable that: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. (2) In the search box in the page, type or paste browser.toolbars.keyboard_navigation and pause while the list is filtered (3) Double-click the preference to switch the value from true to false Does that resolve it?

Unfortunately I don't believe this is my issue. I have a multi monitor set up. When I don't have anything except the full screen application on the primary monitor sometimes when I alt+tab it doesn't switch applications completely. I get control of the mouse, which allows me to click outside of the primary monitor, taking control of another window. Sometimes when this happens I capture a bookmark as if I am attempting to reposition it. Perhaps I am unintentionally clicking on one and as a result it moves positions very rapidly as my monitors readjust. It's hard to judge because I can't actually see my pointer when it happens. I'm going to use BookmarksDropDown and just open a new tab if I want a bookmark. https://addons.mozilla.org/en-US/firefox/addon/bookmarksdropdown/ Kind of obnoxious but I think it's probably the easiest solution.

Read this answer in context 👍 0

All Replies (5)

more options

Beyond the basic bookmark functions anything more would require some kinda Bookmark Addon to do what your asking. Maybe you should open two browser windows one for the game and the other for the bookmark to avoid what your doing as well.

Helpful?

more options

Possibly Windows missed the Alt because it is possible to tab from the address bar to the first bookmark on the Bookmarks Toolbar. To disable that:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future.

(2) In the search box in the page, type or paste browser.toolbars.keyboard_navigation and pause while the list is filtered

(3) Double-click the preference to switch the value from true to false

Does that resolve it?

Helpful?

more options

It is not possible to lock bookmarks you placed on the Bookmarks Toolbar. Note that you can use "Organize -> Undo" in the Bookmarks Manager (Library) to undo such accidental changes as long as you haven't closed Firefox.

Helpful?

more options

Chosen Solution

jscher2000 - Support Volunteer said

Possibly Windows missed the Alt because it is possible to tab from the address bar to the first bookmark on the Bookmarks Toolbar. To disable that: (1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk. More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. (2) In the search box in the page, type or paste browser.toolbars.keyboard_navigation and pause while the list is filtered (3) Double-click the preference to switch the value from true to false Does that resolve it?

Unfortunately I don't believe this is my issue. I have a multi monitor set up. When I don't have anything except the full screen application on the primary monitor sometimes when I alt+tab it doesn't switch applications completely. I get control of the mouse, which allows me to click outside of the primary monitor, taking control of another window. Sometimes when this happens I capture a bookmark as if I am attempting to reposition it. Perhaps I am unintentionally clicking on one and as a result it moves positions very rapidly as my monitors readjust. It's hard to judge because I can't actually see my pointer when it happens. I'm going to use BookmarksDropDown and just open a new tab if I want a bookmark. https://addons.mozilla.org/en-US/firefox/addon/bookmarksdropdown/ Kind of obnoxious but I think it's probably the easiest solution.

Helpful?

more options

Steps are given below-

Set the Bookmarks toolbar to Always Show so that you can see it on all pages. Go to the page you want to add to the Bookmarks toolbar. In the address bar, click and drag the padlock icon onto the Bookmarks toolbar. AddBookmarkToolbar After adding bookmarks, you can reset the Bookmarks toolbar to your preferred setting.

Greeting, Rachel Gomez

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.