Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

I cannot get Indeed to load on Firefox.

  • 3 replies
  • 0 have this problem
  • 4 views
  • Last reply by cor-el

more options

I’m trying to get to www.indeed.com using Firefox. When I get to the website it says, “checking if the site connection is secure, www.indeed.com needs to review the security of your connection before proceeding.” I used inspect to help find the cause of the issue. It says “some cookies are misusing the recommended samesite attribute” the cookie “cf_chl_2” came up 5 times saying “ cf_chl_2” does not have a proper “samesite” attribute value. Soon, cookies without the “samesite” attribute or with an invalid value will be treated as “lax” this means that the cookie will no longer be sent in third-party contexts. If your application depends on this cookie being available in such contexts, please add the “samesite=none” attribute to it. To know more about the “samesite” attribute, read https://developer.mozilla.org/docs/Web/HTTP/Headers/Set-Cookie/SameSite

Another cookie is “cf_chl_rc_m”

I don’t want to make these cookies secure if they could potentially cause my computer harm or steal my info. I tried uninstalling Firefox and reinstalling it but it still kept all of my favorites so I’m assuming it didn’t reset and fix Firefox like I had hoped. I don’t have a firefox account on my computer so I’m not sure how favorites came back. Do you know why?

I am using a MacBook Pro M2 chip 2022 and the latest version of firefox. I have also updated my computer. I have run Norton and found no threats on my computer. And firefox wasn’t giving me this issue before.

What do you think I should do?

Thank you in advance for helping.

I’m trying to get to www.indeed.com using Firefox. When I get to the website it says, “checking if the site connection is secure, www.indeed.com needs to review the security of your connection before proceeding.” I used inspect to help find the cause of the issue. It says “some cookies are misusing the recommended samesite attribute” the cookie “cf_chl_2” came up 5 times saying “ cf_chl_2” does not have a proper “samesite” attribute value. Soon, cookies without the “samesite” attribute or with an invalid value will be treated as “lax” this means that the cookie will no longer be sent in third-party contexts. If your application depends on this cookie being available in such contexts, please add the “samesite=none” attribute to it. To know more about the “samesite” attribute, read https://developer.mozilla.org/docs/Web/HTTP/Headers/Set-Cookie/SameSite Another cookie is “cf_chl_rc_m” I don’t want to make these cookies secure if they could potentially cause my computer harm or steal my info. I tried uninstalling Firefox and reinstalling it but it still kept all of my favorites so I’m assuming it didn’t reset and fix Firefox like I had hoped. I don’t have a firefox account on my computer so I’m not sure how favorites came back. Do you know why? I am using a MacBook Pro M2 chip 2022 and the latest version of firefox. I have also updated my computer. I have run Norton and found no threats on my computer. And firefox wasn’t giving me this issue before. What do you think I should do? Thank you in advance for helping.

All Replies (3)

more options

What happens when the site is checking your connection -- anything? Nothing? They use CloudFront to serve some parts of their site, so you might be seeing something that CloudFront offers to its clients as an extra security check (to block bots from scraping listings).

Regarding SameSite Cookies: I think that message is information for the site developer, and doesn't indicate that Firefox actually is blocking something. SameSite is a feature developers and browsers can use to prevent cookies from leaking to different sites, so it's something that will be helpful when it's enforced, but the last time Firefox tried to enforce it, so many sites stopped working that it had to be rolled back to the warning again.

But that leaves the question of why Indeed or CloudFront is having a problem.

Any difference if you use a private window? You can test that using Ctrl+Shift+P, or right-click (Ctrl+click) a link to the site and use the Open in New Private Window option.

Helpful?

more options

When it’s checking if the connection is secure it just keeps loading, and after a minute or more it reloads the page by itself and try’s again saying it’s checking the connection to see if it’s secure. I noticed every other time it reloads, the insecure cookies sometimes change too. Other times some of the insecure cookies aren’t listing anymore as a problem in inspect but new ones seem to pop up replacing them. I did try to open indeed through an in private tab but the same problem occurred. However, this problem doesn’t seem to be happening in chrome. Thank you for getting back to me, I hope we can resolve this and get indeed working again.

Helpful?

more options

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.