Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Overlapping text

  • 4 replies
  • 0 have this problem
  • 5 views
  • Last reply by cor-el

more options

I've read the forums, i've tried adjustments for days on Win 11 and firefox. Zoomed in zoomed out, adjust font sizes Either it's way too tiny to read or the page is fine but text over laps i've tried the zoom in on text only as well Basically tried everything. enclosing a youtube page for reference

I've read the forums, i've tried adjustments for days on Win 11 and firefox. Zoomed in zoomed out, adjust font sizes Either it's way too tiny to read or the page is fine but text over laps i've tried the zoom in on text only as well Basically tried everything. enclosing a youtube page for reference
Attached screenshots

Chosen solution

If you have made changes to Advanced font-size settings like increasing the minimum/default font-size then try the Default font-size setting "16" and the Minimum font-size setting "none" to see if that makes a difference.

  • Settings -> General -> Language and Appearance -> Fonts -> Advanced -> Minimum Font Size (none)

Make sure you allow pages to choose their own fonts.

  • Settings -> General -> Language and Appearance -> Fonts -> Advanced
    [X] "Allow pages to choose their own fonts, instead of your selections above"

It is better not to increase the minimum font-size, but to use the built-in Firefox Zoom feature.

  • Settings -> General -> Language and Appearance -> Zoom
Read this answer in context 👍 0

All Replies (4)

more options

Could you remove any "minimum" font sizes that might have been set? The problem with the minimum font size is that it doesn't enlarge the space for letters, only the letters, so they can overflow out of their containers. As a quick way to find all of them, you can use this backdoor method:

(1) In a new tab, type or paste about:config in the address bar and press Enter/Return. Click the button accepting the risk.

More info on about:config: Configuration Editor for Firefox. The moderators would like us to remind you that changes made through this back door aren't fully supported and aren't guaranteed to continue working in the future. Since we are restoring default settings, I feel comfortable mentioning it.

(2) In the search box in the page, type or paste font.min and check the box to show only modified preferences. Firefox should list any character sets where your Firefox as a minimum font size set.

(3) For each customized value, click the Reset button at the right end of the row to restore the default value of None (which shows here as 0)

Now Zoom should hopefully work as designed.

(Note: I don't recommend Zoom Text Only because it also has a problem of overflowing fancier layouts.)

Helpful?

more options

hello and thank You

mine doesn't show a reset , only the toggle for true or false.

Helpful?

more options

Okay, none of the minimum sizes were customized. You can use the trash can on that last line since font.min was just meant to be a search filter and not a new preference.

Are you replacing site fonts? On the Settings page, General panel, Fonts section, "Advanced..." button, make sure the box is checked to let pages specify fonts and sizes:

Also make sure you are not using Zoom Text Only, but feel free to select a higher zoom level in the Default zoom selector:

Helpful?

more options

Chosen Solution

If you have made changes to Advanced font-size settings like increasing the minimum/default font-size then try the Default font-size setting "16" and the Minimum font-size setting "none" to see if that makes a difference.

  • Settings -> General -> Language and Appearance -> Fonts -> Advanced -> Minimum Font Size (none)

Make sure you allow pages to choose their own fonts.

  • Settings -> General -> Language and Appearance -> Fonts -> Advanced
    [X] "Allow pages to choose their own fonts, instead of your selections above"

It is better not to increase the minimum font-size, but to use the built-in Firefox Zoom feature.

  • Settings -> General -> Language and Appearance -> Zoom

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.