Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Hide Tab bar if there is only one tab

  • 5 replies
  • 2 have this problem
  • 1211 views
  • Last reply by giltheissen

more options

Hello!

I have been using this userChrome.css code to hide the tab bar if there is only one tab (on Windows):

tab:only-of-type, tab:only-of-type + #tabs-newtab-button {

   display: none !important;

}

#tabbrowser-tabs, #tabbrowser-arrowscrollbox, #tabbrowser-tabs > .tabbrowser-arrowscrollbox {
   min-height: 0 !important;

}

Since one of the recent Firefox updates, this code does no longer work. Maybe because there is a new element in the tab bar: A drop-down list at the right.

Any idea how to make the above code work again?

Peter

Hello! I have been using this userChrome.css code to hide the tab bar if there is only one tab (on Windows): tab:only-of-type, tab:only-of-type + #tabs-newtab-button { display: none !important; } #tabbrowser-tabs, #tabbrowser-arrowscrollbox, #tabbrowser-tabs > .tabbrowser-arrowscrollbox { min-height: 0 !important; } Since one of the recent Firefox updates, this code does no longer work. Maybe because there is a new element in the tab bar: A drop-down list at the right. Any idea how to make the above code work again? Peter

Modified by peter596

Chosen solution

Try this code in userChrome.css with the Firefox View button and the the "List all tabs" (Tab Manager) button hidden/removed.

tab[first-visible-tab=true][last-visible-tab=true],
tab[first-visible-tab=true][last-visible-tab=true] + #tabbrowser-arrowscrollbox-periphery{
  display:none!important;
}
#tabbrowser-tabs, #tabbrowser-arrowscrollbox {min-height: 0 !important;}

Read this answer in context 👍 3

All Replies (5)

more options

You can set browser.tabs.tabmanager.enabled = false on the about:config page to hide the "List all tabs" (Tab Manager) button.

You can open the about:config page via the location/address bar. On the warning page, you can click "Accept the Risk and Continue"to open about:config.

Firefox 106+ has a "Firefox View" button at the left end of the Tab bar that you can remove via "Remove from Tab Bar" via the right-click context menu.

Helpful?

more options

Thanks for the quick help! I have set browser.tabs.tabmanager.enabled = false, and indeed the dropdown button at the right has disappeared. But the + button at the left is still there, so the tab bar still does not disappear. It looks like this

tab:only-of-type, tab:only-of-type + #tabs-newtab-button {

  display: none !important;

}

does no longer work with the current Firefox version. Some change or replacement is needed for this code.

Helpful?

more options

Chosen Solution

Try this code in userChrome.css with the Firefox View button and the the "List all tabs" (Tab Manager) button hidden/removed.

tab[first-visible-tab=true][last-visible-tab=true],
tab[first-visible-tab=true][last-visible-tab=true] + #tabbrowser-arrowscrollbox-periphery{
  display:none!important;
}
#tabbrowser-tabs, #tabbrowser-arrowscrollbox {min-height: 0 !important;}

Helpful?

more options

This works. Thanks a lot!

Helpful?

more options

I had the same problem with FF106 and cor-el's solution worked for me as well. Many thanks.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.