Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Inbox not displaying Thunderbird emails on PC. Please Please help!

  • 20 replies
  • 1 has this problem
  • 67 views
  • Last reply by mcleod6

more options

Hi, My inbox shows that there are messages in the inbox but it does not display them. Any action on the inbox gives the msg. "The current operation on "inbox" did not succeed. The mail server for account (my Optimum acct) responded: IMAP4 server terminated connection." I can see the messages on the Optimum website.

I forwarded my incoming mail to a Gmail account and can see the incoming msgs there. Also as can see them on my Apple phone.

Upgraded to latest version of Thunderbird. No help. Other folders seem okay. When I look at the ImapMail folder, I see the msf file for INBOX but I do not see a file for the inbox emails.

I am on Windows 11 and use MS Defender for security

Please help - Thunderbird is my workhorse and contains all my important files. Thank you! Carol

Hi, My inbox shows that there are messages in the inbox but it does not display them. Any action on the inbox gives the msg. "The current operation on "inbox" did not succeed. The mail server for account (my Optimum acct) responded: IMAP4 server terminated connection." I can see the messages on the Optimum website. I forwarded my incoming mail to a Gmail account and can see the incoming msgs there. Also as can see them on my Apple phone. Upgraded to latest version of Thunderbird. No help. Other folders seem okay. When I look at the ImapMail folder, I see the msf file for INBOX but I do not see a file for the inbox emails. I am on Windows 11 and use MS Defender for security Please help - Thunderbird is my workhorse and contains all my important files. Thank you! Carol

Modified by mcleod6

All Replies (20)

more options

Hello

maybe try to add an exclusion in Windows defender for the mailbox files. I am not confident that it will solve this problem but it may be for the better anyway. Can you check your connection with the Imap server ? Maybe your provider has problems or has changed parameters. You can try to turn on debugging by going to settings / General / (button) Config Editor, set mailnews.imap.loglevel to All (don't forget to save by clicking the checkmark) then go to Tools / Developer tools / Error console, clear with the trash button, try to get new mail, and after failure go back to Tools / Developer tools / Error console and copy / paste the content here. Remove identifying information if necessary.

Helpful?

more options

Thank you for your suggestions. Win Defender would only exclude an .exe file so I added Thunderbird exe as an app to exclude. only result was the TB just hung when I clicked to get mail. So I deleted TB exe from MD defender and was back with the IMAP4 msg.

Hope this is helpful but here is the results of the Developer Tools. It's ugly. Once in Console if I click on ther errors tab I get more than the following. Not sure if you wanted that also.

This page is in Quirks Mode. Page layout may be impacted. For Standards Mode use “”. hiddenWindow.html Successfully loaded OpenPGP library rnp.dll version 0.16+git20220124.f06439f7.MZLA from C:\Program Files\Mozilla Thunderbird\rnp.dll RNPLib.jsm:100:15 Found 0 public keys and 0 secret keys (0 protected, 0 unprotected) RNPLib.jsm:301:15 services.settings: Failed to load last_modified.json: TypeError: NetworkError when attempting to fetch resource. Utils.jsm:330 Layout was forced before the page was fully loaded. If stylesheets are not yet loaded this may cause a flash of unstyled content. aboutconfig.js:470:9 Trying to load C:\Program Files\Mozilla Thunderbird\libotr.dll OTRLib.jsm:64:11 Successfully loaded OTR library C:\Program Files\Mozilla Thunderbird\libotr.dll OTRLib.jsm:72:13 tb.account.size_on_disk - Trying to set an unsigned scalar to a negative number. 2 Relative positioning of table rows and row groups is now supported. This site may need to be updated because it may depend on this feature having no effect. preferences.js:279:2 debuggee 'resource://gre/modules/ConsoleAPIStorage.jsm:155' would run ThreadSafeDevToolsUtils.js:82:13 debuggee 'resource://gre/modules/ConsoleAPIStorage.jsm:155' would run ThreadSafeDevToolsUtils.js:82:13 debuggee 'resource://gre/modules/ConsoleAPIStorage.jsm:155' would run ThreadSafeDevToolsUtils.js:82:13 debuggee 'resource://gre/modules/ConsoleAPIStorage.jsm:155' would run ThreadSafeDevToolsUtils.js:82:13 debuggee 'resource://gre/modules/ConsoleAPIStorage.jsm:155' would run ThreadSafeDevToolsUtils.js:82:13 debuggee 'resource://gre/modules/ConsoleAPIStorage.jsm:155' would run ThreadSafeDevToolsUtils.js:82:13 debuggee 'resource://gre/modules/ConsoleAPIStorage.jsm:155' would run ThreadSafeDevToolsUtils.js:82:13 debuggee 'resource://gre/modules/ConsoleAPIStorage.jsm:155' would run ThreadSafeDevToolsUtils.js:82:13 debuggee 'resource://gre/modules/ConsoleAPIStorage.jsm:155' would run ThreadSafeDevToolsUtils.js:82:13 debuggee 'resource://gre/modules/ConsoleAPIStorage.jsm:155' would run ThreadSafeDevToolsUtils.js:82:13 debuggee 'resource://gre/modules/ConsoleAPIStorage.jsm:155' would run ThreadSafeDevToolsUtils.js:82:13 debuggee 'resource://gre/modules/ConsoleAPIStorage.jsm:155' would run ThreadSafeDevToolsUtils.js:82:13 debuggee 'resource://gre/modules/ConsoleAPIStorage.jsm:155' would run ThreadSafeDevToolsUtils.js:82:13

Helpful?

more options

You can't add a directory exclusion in Windows defender ? I have trouble understanding that, can you provide a screenshot of your Windows defender configuration screen ?

About the log, it's useless there is nothing related to Imap here. Duh, it seems that mailnews.imap.loglevel exists but does nothing. So the real way to generate a log file seems to be according to the mozilla wiki:

set MOZ_LOG=IMAP:5,timestamp set MOZ_LOG_FILE=%USERPROFILE%\Desktop\imap.log "%ProgramFiles(x86)%\Mozilla Thunderbird\thunderbird.exe" or maybe: "%ProgramFiles%\Mozilla Thunderbird\thunderbird.exe"

Enter the 3 instructions on separate lines in a terminal window.

Then if the procedure succeeds (exit Thunderbird before launching it from the command line !), you should find a file named 'imap.log' or 'imap.log.moz_log' on your desktop, then post it here.

Helpful?

more options

Hi gp, Sorry for the delay in responding to your last note. Problems have not gone away. the confusion with setting an exclusion with security is that I excluded the app from the Windows Firewall and that dialogue only accepts *.exe, *.com, and *.icd files. Windows Defender which is the virus protection,etc. wiil accept folder exceptions. I excluded the Thunderbird profile folder but it did not fix the problem.

I tried the cmd line commands you suggested and got an error on the second command...."MOZ_LOG_FILe etc, is not a recognized internal or external command, operable program, or batch file"

Am I doing something wrong?

Helpful?

more options

mcleod6 said

got an error on the second command...."MOZ_LOG_FILe etc, is not a recognized internal or external command, operable program, or batch file"

Strange, should work. Did you begin the line with 'set ' ? The error that you describe looks as if you entered MOZ_LOG_FIL..... where MOZ_LOG_FILE would be interpreted as a program to run, and not set MOZ_LOG_FILE=... where MOZ_LOG_FILE is a variable that is filled with the 'set' instruction

Helpful?

more options

Yes I may have forgotten Set on the second command. I did manage to get through all the commands however no file appeared on the desktop.

Several thoughts. The first two commands were at the users/mcleo/ directory The last command I switched to the root directory. C: Also the directory is Program Files (not x86) with a space. I could only locate that by positioning to the Program Files directory from the C: directory. I would imagine that all commands should be done from the same directory. Which one? Also, should Thunderbird be open when doing these commands?

Helpful?

more options

the space is not strictly necessary because the % characters around do the expansion, but entering the real path can do too. But to work it's necessary for Thunderbird to not run when launching this, because the environment variables created with the set instructions are what is saying it to do the debug thing and this is not passed to an already running program.

Helpful?

more options

So from what directory should I be writing the commands?

Helpful?

more options

mcleod6 said

So from what directory should I be writing the commands?

It don't matter. Theoretically the %% trick allows to use system defined directories. I tried it and it works. Ah, I forgot that by default new Windows version default to a powershell prompt. In this case, you have something like this displayed: PS C:\> if this is true for you, the third instruction will not launch Thunderbird. Just add another line before the 3 others in this case: cmd + enter. You will get another c:\> prompt but without "PS" before. You will get several files on the desktop in fact. Just post the 100 first lines of the imap.log.moz_log file.

Helpful?

more options

Executed the 3 commands from the root directory. Got one file on the desktop - imap.log - it was empty! Tried it again today and it replaced it and it is still empty. Opened it with notepad.

Helpful?

more options

Argh, I tested all of this with Thunderbird 102.5 and it produced a trace all right. Do you use the same Thunderbird version ?

Now, if it's not possible to produce a real trace, one can always try to hit at the problem blindly instead. Try to post a screenshot of the account and the server settings, masking your mail address. From your provider web page, if your settings differ from imap, server:mail.optimum.net, port 993, ssl/tls, it's probably a mistake.

Did you have a working setup with your current provider and then it stopped just out of the blue, or was it a different case, such as you getting a new provider, or setting up a new computer, or whatever other change ?

Test your connectivity to the mail server by installing Telnet client from the Window control panel (it's a windows capability), then run in a command line window:

telnet mail.optimum.net 993

either it hangs while displaying 'connecting to mail.optimum.net...' and displays an error messages after one minute or so (bad, network problem either at the internet box or PC firewall level), or the message disappears after 2 or 3 seconds and the screen goes dark, then hitting enter 2 or 3 times gives a return to the command line prompt c:\>, that is an indication that the network connection was done and there is no blocking.

Also, try troubleshooting mode by holding shift while starting Thunderbird.

Helpful?

more options

I'm on the same level that you are on - it says X64 version but is installed in the Program Files folder (not 64x). I installed it from the Thunderbird site while trying to fix my inbox problem. Evidently, it didn't do that. I am on Windows 11 and have been there since 5/9/22. I migrated from win 10. Not really any changes. I can receive the emails on Apple devices. I forwarded the Thunderbird emails to a gmail account and can see them on that gmail account. I just can't see them in Thunderbird. I can also see them on the Optimum website. Just not the client. It just stopped working. I did do telnet and it starts the connection process but just hangs.. 3 dots and blinking.... I don't understand that because I've had no problems with connectivity.

btw I did spend a fair amount of time using trouble shooting and view others with the same problem on the Thunderbird help website.

Helpful?

more options

If Thunderbird is in Program Files, it's the X64 version. The 32 bits version would have been in the Program Files (X86) directory.

Let's assume it's a connectivity problem, so try to change the firewall. I'll try to describe the thing, sorry if it's not very precise - You'll find easily dozen of tutorials on the Internet.

Click on the start button. You get (normally) a search function. Type 'firewall'. The first option selected should be 'Windows defender firewall'. Click on it. You should go then to a screen saying something like 'Protect your computer with Windows Defender'. To the left you get 4 options, the last one being 'Advanced settings'. Click on it. You should get another screen with to the left 3 'rules' options. Right click on outgoing rules, then choose 'new rule'. Select 'Port' then next. On the following screen enter 993 as port number, then click next. On the following screen select allow to authorize the port (it's important, the default is to block). Then click next until the last screen with a 'finish' button, enter a name for this rule ('authorize imap for thunderbird' for example) and finish.

If you have succeeded, try to *get* mail (note that this is not supposed to help for sending, the port 465 is the one used for sending mail).

Helpful?

more options

Sorry it did not work. Could this have something to do with encryption? When I look at setting for Thunderbird the radio button to enable encryption is grayed out.

Helpful?

more options

For some unknown reason the remote IMAP server does not like my request for mail and terminates the connection.

Helpful?

more options

mcleod6 said

Sorry it did not work. Could this have something to do with encryption? When I look at setting for Thunderbird the radio button to enable encryption is grayed out.

I don't think so, it's probably because you did not enable end-to-end encryption in your account settings - an entirely unrelated problem as the encryption between your computer and the Imap server is NOT end-to-end encryption, it's only while the data is moved between both devices. This is where you have a problem.

I am still fully in the dark on your problem's nature. Is it a connection problem ? I'm attaching a file demonstrating the problem, it's up to you to say if after enabling the rule in the Windows firewall, your computer is still behaving like that or not. Sorry it's in French, but it's the behaviour that counts, not the exact message. When it works, the screen becomes fully black after a few seconds so it's clearly different.

Now, if your connection is proven working, I have another idea. Maybe the security database is corrupted in your system. Could you try to reset it ? I have another thread running with this problem here:

https://support.mozilla.org/en-US/questions/1398174

with exceedingly detailed instructions. Warning, this will destroy all access to passwords stored in your Thunderbird, but if the only one that matters is the Imap access one, it don't matter much since it's not working anyway. You have to know it already.

Helpful?

more options

Hi gp, my telnet instruction acted exactly like your screen shot. It just hangs with the 3 dots and does not go black. However, my prompt is from Microsoft Telnet> and I have to enter o (for open) mail.optimum.net 993 on the command line.

Regarding the PW suggestion, I will try that but probably not until Monday. There are a number of family things going on this weekend so won't get to it till then. Thank you for your continued help. Will be back to you.

Helpful?

more options

btw, just pinged mail.optimum.net and the request timed out. Does that help out?

Helpful?

more options

No, the server don't answer to pings, it's not very good behaviour but quite common.

And the test you do is the same but unfortunately the effect is different. In fact when you are doing this inside of Telnet, the connection is succeeding but you don't see it. You see the difference if you type Enter, if the connection has hanged, there is no change, nothing happens at all, if it has succeeded, at this point the cursor goes back to the upper left of the screen, if you type Enter again, telnet displays 'press a key to continue'. In this case you can differentiate between the 2 cases by using a port that the server is not listening to, for example

o mail.optimum.net 992

if the 2 ports 992 and 993 behave the same, the connection is not working.

Helpful?

more options

Hi gp,

Sorry for dropping off the discussion. Was and still am very, very, busy with family stuff. However, had a break and went back to trying to problem solve my problem inbox problem. To my great surprise and delight when I went back to work on Thunderbird it showed me all the mail in my inbox! Somehow the gremlins are gone and it appears to be working again. I can't believe it! So this is just a note to let you know how appreciative I am for helping me. Though nothing seemed to work, it was helpful to know that someone was there trying to help me. Best to you!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.