Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Need to save disk space - want to delete local Gmail messages

  • 2 replies
  • 0 have this problem
  • 9 views
  • Last reply by talestomaz

more options

Hi all, I have a laptop with a small disk (250 GB) and I need space. I have some 25 GB of Gmail messages locally stored, which are also stored not only in Google servers but in another computer with more space. So I think it's a good idea to remove them from the laptop, synchronising only the headers of the messages (and remote access of the messages, of course). My idea is to uncheck the option "Keep messages in all folders..." in the Synchronisation & Storage area for this account and delete the correct files from my profile folder? Is this a sound approach? Then: what are the "correct" files I should remove? The MBOX (without extension), leaving the *.msf? Would you suggest any other approach? Thanks!

Hi all, I have a laptop with a small disk (250 GB) and I need space. I have some 25 GB of Gmail messages locally stored, which are also stored not only in Google servers but in another computer with more space. So I think it's a good idea to remove them from the laptop, synchronising only the headers of the messages (and remote access of the messages, of course). My idea is to uncheck the option "Keep messages in all folders..." in the Synchronisation & Storage area for this account and delete the correct files from my profile folder? Is this a sound approach? Then: what are the "correct" files I should remove? The MBOX (without extension), leaving the *.msf? Would you suggest any other approach? Thanks!

Chosen solution

re :My idea is to uncheck the option "Keep messages in all folders..." in the Synchronisation & Storage area for this account

Yes, then click on 'Advanced..' button and make sure no checkboxes are selected. Click on OK.

re :delete the correct files from my profile folder

  • Menu icon > Help > More TRoubleshooting Information
  • 'Application Basics' - Profile Folder - click on 'Open Folder'
  • Now Exit Thunderbird - this is important.
  • click on 'ImapMail' folder
  • click on imap mail account name folder

files with .msf extension are index files - keep - leave them alone. Do not delete.

  • mbox (no extension) text files (they have same name as folders) contain emails - either move them to a location where you can store as backup Or delete them.

if you have any folders with .sbd extension -

  • click on .sbd folder and repeat - removing only mbox (no extension) files.

After starting Thunderbird you may want to also reduce the cache.

  • Menu icon > Settings > General
  • scroll to Network & Disk Space
  • Under 'Disk Space' section
  • Your cache is currently using XX MB of disk space - click on 'Clear Now' button
Read this answer in context 👍 0

All Replies (2)

more options

Chosen Solution

re :My idea is to uncheck the option "Keep messages in all folders..." in the Synchronisation & Storage area for this account

Yes, then click on 'Advanced..' button and make sure no checkboxes are selected. Click on OK.

re :delete the correct files from my profile folder

  • Menu icon > Help > More TRoubleshooting Information
  • 'Application Basics' - Profile Folder - click on 'Open Folder'
  • Now Exit Thunderbird - this is important.
  • click on 'ImapMail' folder
  • click on imap mail account name folder

files with .msf extension are index files - keep - leave them alone. Do not delete.

  • mbox (no extension) text files (they have same name as folders) contain emails - either move them to a location where you can store as backup Or delete them.

if you have any folders with .sbd extension -

  • click on .sbd folder and repeat - removing only mbox (no extension) files.

After starting Thunderbird you may want to also reduce the cache.

  • Menu icon > Settings > General
  • scroll to Network & Disk Space
  • Under 'Disk Space' section
  • Your cache is currently using XX MB of disk space - click on 'Clear Now' button

Helpful?

more options

It worked like a charm, thanks!

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.