Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

How to block extension using policies.json

  • 3 replies
  • 0 have this problem
  • 27 views
  • Last reply by Jonathan

more options

Hi, I planned to block my users from installing extensions/add-ons. I found an article that might be the answer (https://support.mozilla.org/en-US/questions/1308646). I tried to create a simple policy (below), but somehow it does not work (I can still install any add-on/extension). What is wrong with my script? I'm using Firefox ESR 78.11.0 (64-bit) by the way.

My "policies.json" looks like this:

{

"policies": {
  "ExtensionSettings": {
    "*": {
      "blocked_install_message": "Blocked!",
      "install_sources": ["https://addons.mozilla.org/"],
      "installation_mode": "blocked"
    }
  }
}

Sincerely, Jonathan

Hi, I planned to block my users from installing extensions/add-ons. I found an article that might be the answer (https://support.mozilla.org/en-US/questions/1308646). I tried to create a simple policy (below), but somehow it does not work (I can still install any add-on/extension). What is wrong with my script? I'm using Firefox ESR 78.11.0 (64-bit) by the way. My "policies.json" looks like this: { "policies": { "ExtensionSettings": { "*": { "blocked_install_message": "Blocked!", "install_sources": ["https://addons.mozilla.org/"], "installation_mode": "blocked" } } } Sincerely, Jonathan

Chosen solution

See:

Note that your curly brackets do not match as you need to add one more '}'. You should see an error on about:policies#errors.

{
 "policies": {
  "ExtensionSettings": {
    "*": {
      "blocked_install_message": "Blocked!",
      "install_sources": ["https://addons.mozilla.org/"],
      "installation_mode": "blocked"
    }
  }.
 }
}

Read this answer in context 👍 0

All Replies (3)

more options

Helpful?

more options

Chosen Solution

See:

Note that your curly brackets do not match as you need to add one more '}'. You should see an error on about:policies#errors.

{
 "policies": {
  "ExtensionSettings": {
    "*": {
      "blocked_install_message": "Blocked!",
      "install_sources": ["https://addons.mozilla.org/"],
      "installation_mode": "blocked"
    }
  }.
 }
}

Helpful?

more options

Cor-El, thank you --- just realized that I missed 1 "}".

Sincerely, Jonathan.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.