Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Missing Folders (and the whole account?) after Thunderbird update (now 102.5.1 64-bit)

  • 10 replies
  • 1 has this problem
  • 45 views
  • Last reply by iomidvar

more options

Starting Thunderbird after a few days, I see none of my folders and in fact my entire email account. Instead I see "Local Folders" and below it "Trash" and "Outbox." There is no trace of any of my emails in any of my folders or in inbox. I would appreciate any help or insight about what has happened. I believe Thunderbird has updated (to 102.5.1 64-bit), but I am not sure.

Starting Thunderbird after a few days, I see none of my folders and in fact my entire email account. Instead I see "Local Folders" and below it "Trash" and "Outbox." There is no trace of any of my emails in any of my folders or in inbox. I would appreciate any help or insight about what has happened. I believe Thunderbird has updated (to 102.5.1 64-bit), but I am not sure.

All Replies (10)

more options

Hello

it may be that there was a new profile created instead of upgrading your existing profile. Try to point to the 'Outbox' folder in your 'Local folders', right click and hit Properties. You'll find the disk path to your profile in the 'location' field. Use it to browse in Explorer (remove the 'mailbox:///' part, start from the drive, c:\ most probably, and remove the part that follows the 'profiles' part) to find the profiles directory. Then look at the size and dates of the directories. If you find one that has a previous date than your profile and is bigger, this is probably your original profile. Check also the beginning of the path: is it under your personal directory ?

Helpful?

more options

gp, thank you very much for your answer. I followed your directions. And here is the information I found. The profiles directory is in my personal directory, and when I go to the profiles directory in Windows Explorer I see two directories. One of the directories (several odd characters followed by "default") is bare bones. The other (odd characters followed by "default-release") has lots of folders and files and includes a directory called "webaccountMail" where I can find another directory called "outlook.office365.com." In that directory I find a directory titled "Inbox.sbd." In that directory, there are several ".msf" files with titles that correspond to my original "Inbox" subfolders, which now have disappeared from Thunderbird. Interestingly, in the properties for the "outbox" folder, the address points to the "default-release" directory, where (a few subdirectories below it) the .msf files corresponding to my "Inbox" subfolders are. Any thoughts on what all this means about why TB cannot see the subfolders? Thanks in advance.

Helpful?

more options

iomidvar said

The other (odd characters followed by "default-release")

This seems the one to watch.

iomidvar said

includes a directory called "webaccountMail" where I can find another directory called "outlook.office365.com."

This looks like an Imap configuration, however I don't see from where is coming this 'webaccountMail' directory. Searching current Thunderbird code, I don't find this string of characters. Searching the Intarweb for this, I can find something about Exchange. Do you have an account for connecting to this thing, with a (paid) add-on such as Owl maybe ?

Helpful?

more options

Hi gp; Yes, I had Owl for Exchange. After your response, I looked for my add-ons in TB, and saw that Owl for Exchange was unselected/turned off. I turned it back on, but it made no difference. In fact, I think, Owl for Exchange is no longer configured for an account.

Helpful?

more options

In this case your 'webaccountMail' directory is not relevant. Can you post a screenshot of the server settings for your account ?

Helpful?

more options

Hi gp, I am sorry if my lack of knowledge has mis-framed the problem. I say this because when I go to TB, I find that there is actually no email account at all associated with TB. That of course means that when I try to look up the server settings by first going to the account settings, I find no options under server settings that I can select in order to get to the server setting options box. So maybe the problem is larger than just my having lost my profile and subfolders? It looks like after the update, I am no longer connected to my (or any) email server at all. I can always try to "add an account" and reconnect to the email server, but I worry that doing so will mean having to re-download tens of thousands of emails again and reorganize them in subfolders, a grueling task that took weeks when I did that work a few months ago.

Helpful?

more options

Your problem is a bit mysterious, the more so because you are not sure if you updated (your first post), while you know that after the update you are no longer connected (last post). I still have zero information on what was the situation when it worked and what happened exactly. Can you post a screenshot of your Mail directory (the one where you found a 'webaccountmail' subdirectory) ? Can you search your hard disk(s) every place where there are .msf files or files called 'Inbox', to see if there are any outside this directory ?

Helpful?

more options

Hi gp, I am attaching three screenshots. I also did a search of my C:\ drive for ".msf" and "Inbox" files. Here is what I found:

  • I see very few .msf files in folders right under “default-release\” itself.
  • The vast majority of .msf files are under “default-release\webaccountmail” and its subfolders especially "* default-release\webaccountmail\outlook.office365.com" and its subfolders
  • I also have Portable Thunderbird on C:\ for old files, so there are some .msf files under “ThunderbirdPortable\Data\Profile\Mail


The only "inbox" files I can find that are not a PNG file or an Internet Shortcut or a compressed file are these:

  • There is a file titled "Inbox"; File Explorer says it is of the file type "File" (?); it is under "default-release\WebaccountMail"
  • There is an "Inbox.msf" file under the same folder as above.

Besides these two files, there are three folders that are called "Inbox":

  • One is a folder in Fax (C:\Users\...\Documents)
  • One is a folder in Mail from Webmail (C:\Users\...\Sync\...\Family\Archive\Work-Related\Jobs\)
  • One is a folder titled Inbox.sbd; under "default-release\webaccountMail"

I hope this information is helpful.

Helpful?

more options

Your problem still seems a bit unclear I'm afraid. You have an account for a corporate server since related data is in a 'webaccountmail' directory, related to an add-on (Owl) that you no longer have installed on your computer. How do you plan to reconnect to this corporate server without the add-on is not easy to understand.

I don't know about Owl, but with another more well-known Exchange client called Outlook, you don't 'download' data actually; the data is stored on the server, if you connect to it it will be restored with all the subfolders. What you see under the Inbox.sbd directory ('sbd' means 'sub-directory') are just caches of the server data. It is making sense that the access could be garbled if you uninstalled the add-on that was providing access to the server data, and some sense that repairing this cache just emptied it. It is based on server data that is no longer available (without the add-on)

So if you still have access to the corporate server AND the add-on, all you need to do is to recreate a new account and you will get back everything (BUT the archives, that is, the data you could have stored in personal files, much like it's done in Outlook with .pst files, this data should be under 'Local Folders' in Thunderbird).

Helpful?

more options

Thanks, gp. I will go ahead and recreate a new account later today and hope for the best. I will let you know how things go.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.