Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

Google safesearch

  • 7 replies
  • 0 have this problem
  • 51 views
  • Last reply by roman94994

more options

Hello. I have a problem with turning off google safesearch. I'm 28 years old so it's not a problem with google acc. I have same firefox on pc and on laptop. On pc and on smarthphone it's easily turning off and if i'm using edge or chrome on laptop it's also turned off, but if i'm using firefox exactly on google it's always turned on no matter what i'm do. Just in case, if i'm using for example bing search in firefox it's also turned off, likely it's always turned when i'm using google with combination in firefox. Methods that I already tried: 1) Turned off in computer settings (not worked) 2) Reinstalled browser (not worked) 3) Checked in my wifi settings (not worked) 4) Updated everything (not worked) Waiting for your help.

Hello. I have a problem with turning off google safesearch. I'm 28 years old so it's not a problem with google acc. I have same firefox on pc and on laptop. On pc and on smarthphone it's easily turning off and if i'm using edge or chrome on laptop it's also turned off, but if i'm using firefox exactly on google it's always turned on no matter what i'm do. Just in case, if i'm using for example bing search in firefox it's also turned off, likely it's always turned when i'm using google with combination in firefox. Methods that I already tried: 1) Turned off in computer settings (not worked) 2) Reinstalled browser (not worked) 3) Checked in my wifi settings (not worked) 4) Updated everything (not worked) Waiting for your help.

Chosen solution

All Replies (7)

more options

What about the Settings button bottom right of the G search page? Search Settings > SafeSearch off.

Helpful?

more options

Also not working. It's says to me that it disables, but when i returns on google search page it's written that safe search enabled.

Helpful?

more options

Maybe the safe search is locked on. https://support.google.com/websearch/answer/510

Helpful?

more options

James said

Maybe the safe search is locked on. https://support.google.com/websearch/answer/510

I think it's kind of bug in firefox. Because in my google account when you login in on other devices safe search turned off. It's on only in firefox on my laptop. Also on the laptop if i go to google through chrome or edge it's turned off.

Problem looks like the same as here >> https://answers.microsoft.com/en-us/bing/forum/bing_safety-bing_safesearch/turning-off-safe-search-with-it-reverting-back-to/66a1d9bf-8cd8-449f-9a51-aa8064a577b3?messageId=40dc0b27-da90-40bf-984c-475a883cfdc3 but this fix don't work on google.

Helpful?

more options

Chosen Solution

You could try clearing cookies for that domain.

https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox

Helpful?

more options

Since this is a Google site your on - I find it hard to see this can be caused by Firefox since that settings is from Google. com site itself. Sounds more like Addons installed on Firefox is causing the settings to not set when checked or unchecked. I can go to google. com and check on the box and uncheck the box. Maybe try in Private Mode browser and go to google. com again and see what happens.

Helpful?

more options

Terry said

You could try clearing cookies for that domain. https://support.mozilla.org/en-US/kb/clear-cookies-and-site-data-firefox

Thank you. Deleting cookies for google helped me.

Helpful?

Ask a question

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.