Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

The jpegs on the Washington Post website don't load (photos of the day). Why?

  • 2 replies
  • 1 has this problem
  • 3 views
  • Last reply by cor-el

more options

It is only the series' of photos that never load:

http://www.washingtonpost.com/realestate/distinguished-homes/2011/12/19/gIQA3lJIQQ_gallery.html?hpid=z7

Other photos load okay. Also, videos on the Post never load.

Thanks. Jane

It is only the series' of photos that never load: http://www.washingtonpost.com/realestate/distinguished-homes/2011/12/19/gIQA3lJIQQ_gallery.html?hpid=z7 Other photos load okay. Also, videos on the Post never load. Thanks. Jane

All Replies (2)

more options

Hello mjkellyview, any luck if clear both cookies and the cache. Note: This will temporarily log you out of all sites you're logged in to. To clear cache and cookies do the following:

  1. Go to Firefox > History > Clear recent history or (if no Firefox button is shown) go to Tools > Clear recent history.
  2. Under "Time range to clear", select "Everything".
  3. Now, click the arrow next to Details to toggle the Details list active.
  4. From the details list, check Cache and Cookies and uncheck everything else.
  5. Now click the Clear now button.

Further information can be found in the Clear your cache, history and other personal information in Firefox article.

also please Update Firefox to the latest version, 19.0 version is vulnerable.

Thank you.

more options

If images are missing then check that you aren't blocking images from some domains.

  • Press the F10 key or tap the Alt key to bring up the hidden "Menu Bar" temporarily.
  • Check the permissions for the domain in the currently selected tab in "Tools > Page Info > Permissions"
  • Check "Tools > Page Info > Media" for blocked images
  • Select the first image link and use the cursor Down key to scroll through the list.
  • If an image in the list is grayed and "Block Images from..." has a check-mark then remove this check-mark to unblock images from this domain.

Make sure that you do not block (third-party) images, the permissions.default.image pref on the about:config page should be 1.


Make sure that you haven't enabled a High Contrast theme in the Windows/Mac Accessibility settings.

Make sure that you allow pages to choose their own colors.

  • Tools > Options > Content : Fonts & Colors > Colors : [X] "Allow pages to choose their own colors, instead of my selections above"

Note that these settings affect background images.

See also:


There are extensions like Adblock Plus (Firefox/Tools > Add-ons > Extensions) and security software (firewall, anti-virus) that can block images and other content.

See also: