Showing questions tagged: Show all questions

youtube livestreams bloated RAM usage, max CPU usage, even at 144p

incoming streams are unusable, bloats RAM to max, pegs CPU at 100% even when stream is at 144p. ongoing issue for over a year. Tried different cache settings or no cache.… (read more)

incoming streams are unusable, bloats RAM to max, pegs CPU at 100% even when stream is at 144p. ongoing issue for over a year. Tried different cache settings or no cache. No fix

FF v107.0 MX Linux

[code] System: Kernel: 4.19.0-22-amd64 x86_64 bits: 64 compiler: gcc v: 8.3.0

          parameters: BOOT_IMAGE=/boot/vmlinuz-4.19.0-22-amd64 
          root=UUID=<filter> ro libata.force=noncq 
          libata.force=3.0G libata.force=noncq libata.force=3.0G 
          Desktop: Xfce 4.14.2 tk: Gtk 3.24.5 info: xfce4-panel wm: xfwm 4.14.0 vt: 7 
          dm: LightDM 1.26.0 Distro: MX-19.4_x64 patito feo May 31  2020 
          base: Debian GNU/Linux 10 (buster) 

Machine: Type: Desktop Mobo: ASUSTeK model: M4A785-M v: Rev X.0x serial: <filter>

          BIOS: American Megatrends v: 1101 date: 11/20/2012 

CPU: Info: Dual Core model: AMD Athlon II X2 B26 bits: 64 type: MCP arch: K10

          family: 10 (16) model-id: 6 stepping: 3 microcode: 10000C8 cache: L2: 2 MiB 
          flags: lm nx pae sse sse2 sse3 sse4a svm bogomips: 12857 
          Speed: 800 MHz min/max: 800/3200 MHz Core speeds (MHz): 1: 800 2: 1900 
          Vulnerabilities: Type: itlb_multihit status: Not affected 
          Type: l1tf status: Not affected 
          Type: mds status: Not affected 
          Type: meltdown status: Not affected 
          Type: mmio_stale_data status: Not affected 
          Type: spec_store_bypass status: Not affected 
          Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer sanitization 
          Type: spectre_v2 
          mitigation: Retpolines, STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected 
          Type: srbds status: Not affected 
          Type: tsx_async_abort status: Not affected 

Graphics: Device-1: NVIDIA GT218 [GeForce 8400 GS Rev. 3] vendor: eVga.com. driver: nvidia

          v: 340.108 bus-ID: 01:00.0 chip-ID: 10de:10c3 class-ID: 0300 
          Device-2: Logitech B525 HD Webcam type: USB driver: snd-usb-audio,uvcvideo 
          bus-ID: 1-6:3 chip-ID: 046d:0836 class-ID: 0e02 serial: <filter> 
          Display: x11 server: X.Org 1.20.4 compositor: xfwm4 v: 4.14.0 driver: loaded: nvidia 
          display-ID: :0.0 screens: 1 
          Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x286mm (20.0x11.3") 
          s-diag: 583mm (23") 
          Monitor-1: VGA-0 res: 1920x1080 hz: 60 dpi: 102 size: 476x268mm (18.7x10.6") 
          diag: 546mm (21.5") 
          OpenGL: renderer: GeForce 8400GS/PCIe/SSE2 v: 3.3.0 NVIDIA 340.108 direct render: Yes 

Audio: Device-1: AMD SBx00 Azalia vendor: ASUSTeK M4A785TD driver: snd_hda_intel v: kernel

          bus-ID: 00:14.2 chip-ID: 1002:4383 class-ID: 0403 
          Device-2: NVIDIA High Definition Audio vendor: eVga.com. driver: snd_hda_intel 
          v: kernel bus-ID: 01:00.1 chip-ID: 10de:0be3 class-ID: 0403 
          Device-3: Logitech B525 HD Webcam type: USB driver: snd-usb-audio,uvcvideo 
          bus-ID: 1-6:3 chip-ID: 046d:0836 class-ID: 0e02 serial: <filter> 
          Sound Server-1: ALSA v: k4.19.0-22-amd64 running: yes 
          Sound Server-2: JACK v: 1.9.12 running: no 
          Sound Server-3: PulseAudio v: 12.2 running: yes 

Network: Device-1: Ralink RT5392 PCIe Wireless Network Adapter driver: rt2800pci v: 2.3.0

          modules: wl port: dc00 bus-ID: 02:00.0 chip-ID: 1814:5392 class-ID: 0280 
          IF: wlan0 state: up mac: <filter> 
          Device-2: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
          vendor: ASUSTeK M4A785TD driver: r8169 v: kernel port: e800 bus-ID: 03:00.0 
          chip-ID: 10ec:8168 class-ID: 0200 
          IF: eth0 state: down mac: <filter> 

Drives: Local Storage: total: 126.71 GiB used: 103.07 GiB (81.3%)

          SMART Message: Unable to run smartctl. Root privileges required. 
          ID-1: /dev/sda maj-min: 8:0 vendor: Crucial model: CT120BX500SSD1 size: 111.79 GiB 
          block-size: physical: 512 B logical: 512 B speed: <unknown> type: SSD 
          serial: <filter> rev: R013 scheme: MBR 
          ID-2: /dev/sdb maj-min: 8:16 type: USB vendor: Lexar model: USB Flash Drive 
          size: 14.92 GiB block-size: physical: 512 B logical: 512 B type: SSD serial: <filter> 
          rev: 8.07 scheme: MBR 
          SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 

Partition: ID-1: / raw-size: 18.55 GiB size: 18.09 GiB (97.52%) used: 12.98 GiB (71.7%) fs: ext4

          dev: /dev/sda4 maj-min: 8:4 
          ID-2: /home raw-size: 87.38 GiB size: 85.45 GiB (97.80%) used: 80.84 GiB (94.6%) 
          fs: ext4 dev: /dev/sda3 maj-min: 8:3 

Swap: Kernel: swappiness: 15 (default 60) cache-pressure: 100 (default)

          ID-1: swap-1 type: partition size: 2.93 GiB used: 524 KiB (0.0%) priority: -2 
          dev: /dev/sda2 maj-min: 8:2 

Sensors: System Temperatures: cpu: 37.0 C mobo: 48.0 C gpu: nvidia temp: 49 C

          Fan Speeds (RPM): cpu: 3229 case-1: 2327 gpu: nvidia fan: 40% 
          Power: 12v: 12.52 5v: N/A 3.3v: 3.31 vbat: N/A 

Repos: Packages: note: see --pkg apt: 2981 lib: 1586 flatpak: 0

          No active apt repos in: /etc/apt/sources.list 
          Active apt repos in: /etc/apt/sources.list.d/airvpn-stable.list 
          1: deb http://eddie.website/repository/apt/ stable main
          Active apt repos in: /etc/apt/sources.list.d/debian-stable-updates.list 
          1: deb http://deb.debian.org/debian/ buster-updates main contrib non-free
          Active apt repos in: /etc/apt/sources.list.d/debian.list 
          1: deb http://deb.debian.org/debian/ buster main contrib non-free
          2: deb http://deb.debian.org/debian-security/ buster/updates non-free contrib main
          3: deb http://deb.debian.org/debian/ buster-backports non-free contrib main
          Active apt repos in: /etc/apt/sources.list.d/megasync.list 
          1: deb [signed-by=/usr/share/keyrings/meganz-archive-keyring.gpg] https://mega.nz/linux/repo/Debian_10.0/ ./
          Active apt repos in: /etc/apt/sources.list.d/mx.list 
          1: deb http://mirror.its.dal.ca/mxlinux/mx/repo/ buster main non-free
          Active apt repos in: /etc/apt/sources.list.d/skype-stable.list 
          1: deb [arch=amd64] https://repo.skype.com/deb stable main
          Active apt repos in: /etc/apt/sources.list.d/slack.list 
          1: deb https://packagecloud.io/slacktechnologies/slack/debian/ jessie main
          No active apt repos in: /etc/apt/sources.list.d/spotify.list 
          No active apt repos in: /etc/apt/sources.list.d/various.list 

Info: Processes: 244 Uptime: 23h 27m wakeups: 2 Memory: 7.79 GiB used: 3.82 GiB (49.0%)

          Init: SysVinit v: 2.93 runlevel: 5 default: 5 tool: systemctl Compilers: gcc: 8.3.0 
          alt: 8 Shell: quick-system-in default: Bash v: 5.0.3 running-in: quick-system-in 
          inxi: 3.3.06 

/code

Asked by Galen Thurber 20 hours ago

Last reply by Galen Thurber 1 hour ago

How to disable file overwrite dialog?

So, I am a Linux user who is used to shell commands like mv or cp. One of their feature is absence of prompts like "Are you sure what you want to replace foo.txt?". Becau… (read more)

So, I am a Linux user who is used to shell commands like mv or cp. One of their feature is absence of prompts like "Are you sure what you want to replace foo.txt?". Because I have somewhat organized fs, I always know what that file is for and if I can overwrite it.


Now I have to download some files, what I need only for uploading onto another website / reading them once. So, I just download them into my /tmp folder and save them under the same name (so I could just repeat cat command and reduce clutter). But each time I download a file Firefox asks for confirmation to replace my existing file. Are there any config flags to disable those annoying prompts?

Asked by i-s-d 1 day ago

Arabic font not looking good on facebook after reinstalling snap version of firefox on ubuntu 22.044

Hi The Arabic font broken on Facebook after reinstalling snap version of Firefox 107 on Ubuntu 22.04 given that the font on YouTube search look fine (but not on Facebook)… (read more)

Hi

The Arabic font broken on Facebook after reinstalling snap version of Firefox 107 on Ubuntu 22.04 given that the font on YouTube search look fine (but not on Facebook). I tried to reinstall Firefox in multiple ways like using the deb version reinstalling the snap one removing the .cache folder and logging out of the session and even rebooting my PC.

Why is my firefox is broken?

what is the solution ? it would be really appreciated

Asked by capacity213 1 week ago

Last reply by capacity213 1 day ago

Website firewall

hi, i can not visit this website on firefox for linux. https://api.szfx.top/bing/api/?day=0 the uploaded image says that in chinese : Your request has illegal parameters … (read more)

hi, i can not visit this website on firefox for linux. https://api.szfx.top/bing/api/?day=0

the uploaded image says that in chinese : Your request has illegal parameters and has been blocked by the website administrator!

the firewall service is supported by Pagoda Website Firewall Free Edition, which website is https://www.bt.cn/new/index.html

thank you for help!

Asked by 337 2 days ago

Recording sound on Linux

Hi! I would like to record sound from Firefox on Linux. However, every time sound stops playing(i.e. a video is paused), the sound channel disappears, and when the sound … (read more)

Hi!

I would like to record sound from Firefox on Linux. However, every time sound stops playing(i.e. a video is paused), the sound channel disappears, and when the sound resumes playing, a new sound channel is created. This makes it near impossible to consistently record sound, since all the sound connections disappear along with the sound channel, and they have to be reconnected manually.

Is there a way to force Firefox to always use a single sound channel for everything, or create a sound channel for every tab, regardless of whether sound is actually playing?

I am using Firefox 107.0-1 on Arch Linux 6.0.9-arch1-1, with pipewire 1:0.3.60-3.

Thanks in advance, GOBLIN

Asked by deergoduc 2 days ago

TLS decryption with SSLKEYLOGFILE

Hi, I am currently working on a privacy study regarding Mozilla Firefox and I would like to have more detailed information on key log file using per-session secrets. I us… (read more)

Hi,

I am currently working on a privacy study regarding Mozilla Firefox and I would like to have more detailed information on key log file using per-session secrets.

I used SSLKEYLOGFILE environment variable from underlying NSS library to get TLS session secrets [1], which can be used in Wireshark to decrypt HTTPS traffic. I looked at Firefox documentation for some answers and I found that NSS support for logging file is disabled by default since NSS 3.24 [2], that-is to say Firefox 48 and 49 [3]. I do not have found any documentation saying it has been re-enabled by default since then. However, I have made some tests on Ubuntu 22.04 LTS (it is disabled on Debian) and Windows 10 using Firefox 106 (NSS 3.83) [4] and it works properly.

So, I have two questions : - Is it normal that this feature still works for decrypting traffic whereas it should be disabled by default ? - What is the position of Mozilla developers and the community on the security of this feature (anyone who have access to someone computer could get all of their internet passwords) ?

Thank you for your reading and I am looking forward to reading your answer.

Best regards


[1] https://wiki.wireshark.org/TLS [2] https://firefox-source-docs.mozilla.org/security/nss/legacy/nss_releases/nss_3.24_release_notes/index.html#mozilla-projects-nss-nss-3-24-release-notes [3] https://firefox-source-docs.mozilla.org/security/nss/legacy/key_log_format/index.html [4] https://wiki.mozilla.org/NSS:Release_Versions

Asked by hbove 4 days ago

Click on jar:file:///local_dir_path/xxx-javadoc.jar!/index.html doesn't work

On my personal home page, I have several links as in the subject: which I use to browse javadoc. Clicking on the link does nothing AFAICT. Is there some kind of configura… (read more)

On my personal home page, I have several links as in the subject: which I use to browse javadoc. Clicking on the link does nothing AFAICT. Is there some kind of configuration setting to get the "click" to work? (It used to work years ago)

There are some workarounds

Workaround One

  1. Copy Link (context menu action)
  2. Ctrl-L
  3. Paste link in search/open bar
  4. Return

Workaround Two

  1. Open Link in New Tab (context menu action)
  2. Click on New Tab
  3. Ctrl-L
  4. Return

Workaround two leave an unwanted open tab

Asked by err778 4 days ago

Import data from another profile

When installing Firefox, there is an option to import data from another browser. That feature is also available in the "Library -> Import and Backup -> Import data … (read more)

When installing Firefox, there is an option to import data from another browser. That feature is also available in the "Library -> Import and Backup -> Import data from Another Browser", and it imports things like Bookmarks and History from another browsers.

As the functionality already exists, is it possible to use that functionality in any way to import Bookmarks and History from a different profile in the same Firefox installation? I want to merge 2 different browsing history (like the old question https://support.mozilla.org/en-US/questions/928204), and looks like using the "Import data from Another Browser" could help if it's possible to use it with another Firefox profile/directory.

Asked by Illian J 6 days ago

Last reply by Illian J 5 days ago

Credit card numbers repeatedly stop working

I've been dealing with this same problem repeatedly for over 2 years now. It appears to be what a number of threads appear to address, but their solutions don't really w… (read more)

I've been dealing with this same problem repeatedly for over 2 years now. It appears to be what a number of threads appear to address, but their solutions don't really work. For example, this one: https://support.mozilla.org/en-US/questions/1360287

Problem: I enter a credit card number I'd like Firefox to remember. It works once--the first time after I enter it. Then in the future, I try to use it again. I get the option to use it from a dropdown autofill menu (it shows the cards I've used in the past, including the card's number as x's except the final number: like xxxx xxxx xxxx 1837. I select one, but it doesn't fill in the box with the number. I can try to select it with the mouse, the tab key, etc. but nothing results in it filling the box, despite the fact that it appears to have the number there (as evidenced by the xxxx 1837 number, the address, my name, the expiration, etc.).

I decide to reenter it. It works again that time, but then stops working shortly there after (a few weeks later).

My system is firefox for Linux 107.0 (64-bit) " Firefox Release November 15, 2022.

I can also confirm that I've followed the support suggestions to double check the about:config info: extensions.formautofill.creditCards.available extensions.formautofill.creditCards.enabled

(Some of the "solutions" I've used in the past have focused on other options.) Most recently I double checked that one, but all the about:config options I can find on credit cards have the options selected that it would appear they would need to work correctly. (See image below)


None of this seems to work; it's pretty annoying to see people "think" they solve the problem, but their "fix" only works for one use.

So I have some questions: -Could this be specific to the Linux version of Firefox? -Could it be that since I run Arch Linux (with frequent updates) something that updates repeatedly 'resets' some portion of the credit card info? (Would it still show "xxxx xxxx xxxx 1837" and the right expiration, address, etc. if it were reset by something?) -Could it have something to do with Firefox's sync? I use this same firefox account on 3 devices, even though 90% of my time is on my desktop Linux system

Asked by rabarrettbus 5 days ago

How to remove duplicated entries in history only differenced by URI fragment

When navigating in some pages, specially in google docs, the browser's URI fragment (the part after the #) changes frequently for each page/header/slide, and all of them … (read more)

When navigating in some pages, specially in google docs, the browser's URI fragment (the part after the #) changes frequently for each page/header/slide, and all of them are stored in the history.

That behavior adds lots of entries in the history and also hinders the usage of the search functionality of the address bar (as all the duplicates are shown instead of shown only one and other pages). I want to keep one entry per document, at least in specific pages like gdocs where the "fragment" doesn't add any useful information and each document can have lots of them.

Is there any way to configure that behavior, to not save every fragment in the history?


To reproduce the above behavior (the same behavior happens in other pages, not only gdocs):

- Open any gdocs document with several headers, or a gdocs presentation with several pages. - Navigate all the document/presentation, and check the history. - Close the document/presentation tab/window. - In a new window/tab, use the address bar to search the document/presentation by the document name: several entries for the same document/presentation are shown (and if they are lots of them, no other different entries with same words are shown in the address bar). - Check also the history: several entries of the same document/presentation are shown (it could be hundreds for long documents, and thousands after seen few documents).

Asked by Illian J 6 days ago

Last reply by Illian J 6 days ago