Firefox and Tor both wont launch if installed in default location

If i move the directory to anywhere else it launches In the default location it wont launch - No errors - cannot launch in profile manager mode - cannot launch via cmd -… (read more)

If i move the directory to anywhere else it launches In the default location it wont launch - No errors - cannot launch in profile manager mode - cannot launch via cmd - cannot by going to C:\Program Files\Mozilla Firefox\ and launching firefox.exe literally nothing happens

Asked by Nixos 6 minutes ago

Last reply by Nixos 3 minutes ago

The HTML files generated by using the menu option "Save Page As" don't work properly.

I saved a lot of pages using the option "Save Page As", mostly Reddit posts. The problem is, each time I try to open one of these HTM/HTML files they just don't load prop… (read more)

I saved a lot of pages using the option "Save Page As", mostly Reddit posts. The problem is, each time I try to open one of these HTM/HTML files they just don't load properly. The page loads properly for a split second and then the "body" of the page (by body I mean the main part where the content is) dissapears.

At the beginning I thought it was a Reddit problem, but I tried with different sites and it's always the same result or even worse. I opened these HTM/HTML files with different browsers and the result is also the same. In that moment I was using something lower than Firefox 105.0.0, now I'm using 105.0.2.

I would like to make this files work, but if that isn't possible, I'd like to extract the URL from this files so I can still read them and delete them later, but I need a massive way to extract these URL because I have over 1000 of these files. Thanks in advance.

Asked by el_seba_94 37 minutes ago

Documentation files I need no longer exist

I need Firefox_ESR 52.9 which is the last release that supports an add-on I need for a standalone application (i.e NO INTERNET) to run on 32bit and 64bit Debian Bullseye … (read more)

I need Firefox_ESR 52.9 which is the last release that supports an add-on I need for a standalone application (i.e NO INTERNET) to run on 32bit and 64bit Debian Bullseye Raspberry Pi. I don't know if it can be done but I want to try and see if I can build it. I downloaded the source. I'd like to consult with documentation first but the README.txt file points to two pages that don't exist anymore: https://developer.mozilla.org/en/Mozilla_Source_Code_Directory_Structure http://developer.mozilla.org/en/docs/Build_Documentation

If anyone can provide me with the documentation from their way-back machine and/or assist me, I'd be very appreciative.

The application needs the original mkiosk add-on (not the current one) and this is the last Firefox revision to support it. The application is something I provided to our museum and I wrote the hundred+ web pages for it but it was written for wheezy, not bullseye and I want to run it on an RPI4 instead. I donated hundreds of hours of work as well as all the hardware (including a touchscreen monitor) to the museum. I have no intention of otherwise using the application except for similar projects or selling it for any reason whatsoever.

Actually, what would be more wonderful if someone had ported that mkiosk version to current Firefox. It has some unique features.

All my work on this, and other applications I have written, have been freely donated and, at my age, I don't intend to change that policy.

Asked by jpezz 2 hours ago

Last reply by jpezz 1 hour ago

Logins don't sync even when told to

I have logins enabled to be synchronized on my account but they do not synchronize. I've removed and re-added devices. I've made sure both are on the same account. Both c… (read more)

I have logins enabled to be synchronized on my account but they do not synchronize. I've removed and re-added devices. I've made sure both are on the same account. Both computers have the most up-to-date version of Firefox. One has 14 logins the other has 448.

Asked by Marshall 1 hour ago

Videos won't play in Firefox, fine in other browsers

I seem to have that bug that was fixed a few updates ago where videos won't play. I have the latest version of Firefox. For example, YouTube will load and the page, prog… (read more)

I seem to have that bug that was fixed a few updates ago where videos won't play. I have the latest version of Firefox. For example, YouTube will load and the page, progress bar and even subtitles will show, but the video will just have the spinning circle. I have tried videos on other websites (Facebook, Tumblr) and they won't play either.

I've uninstalled/reinstalled Firefox, refreshed Firefox, disabled all add-ons, allowed autoplay of videos/audio but nothing works. The videos all work on Chrome and Edge.

Asked by ejayneh 2 hours ago

I synced my Google bookmarks onto my firefox browser and lost all my firefox bookmarks, can I get them back

I stupidly exported my Google browser bookmarks to Firefox when setting up on a new device and lost all my firefox bookmarks from all my other devices as a result. I am u… (read more)

I stupidly exported my Google browser bookmarks to Firefox when setting up on a new device and lost all my firefox bookmarks from all my other devices as a result. I am utterly horrified and freaking out - it's years of bookmarked articles that I'd even organised into folders! Is there any way to get them back?

Asked by Andorean84 4 days ago

Last reply by Andorean84 2 hours ago

Kiosk capability like old Mkiosk add-on? Need suggestions

Ending in 52.X, one of the old add-ons called mkiosk was really wonderful. It had all sorts of configurable options including one that was critical to my free application… (read more)

Ending in 52.X, one of the old add-ons called mkiosk was really wonderful. It had all sorts of configurable options including one that was critical to my free application of Firefox-ESR used by some non-profits. That feature was a timeout such that if the user walked away while not in the "home" web page, a configurable parameter returned firefox to that "home" page. I have not found this feature anywhere else. Unfortunately, installing 52.X on a standalone current bullseye version for the Raspberry Pi is turning out to be problematic. Is there any way to resolve this issue?

Some ideas: 1) Find out how to make Firefox accept an obsolete add-on 2) Fins out how to tell with an external program what page Firefox is on and by periodically polling it, kill and restart Firefox if the time on that page exceeds a certain limit. On the old mkiosk, I set 5 minutes.

Any help here? I'm not a json person so even editing the old mkiosk is beyond me.

Asked by jpezz 3 weeks ago

Last reply by jpezz 2 hours ago

firefox wont start. have tried nearly everything to remove and re-install

Firefox stopped working today. Every time I launch it, it responds with: "Firefox is already running, but is not responding. The old Firefox process must be closed to o… (read more)

Firefox stopped working today. Every time I launch it, it responds with: "Firefox is already running, but is not responding. The old Firefox process must be closed to open a new window."

I launched Task Manager and killed the active processes, relaunched ff - did not resolve the issue.

I have uninstalled and reinstalled ff multiple times - did not resolve the issue.

I have removed the lock as per here: https://support.mozilla.org/en-US/kb/firefox-already-running-not-responding#:~:text=Right%2Dclick%20on%20an%20empty,it)%20and%20click%20End%20Process.

I have verified the access rights as per here: https://www.minitool.com/news/fix-firefox-is-already-running-but-is-not-responding.html

I have completely removed all the mozilla entries from both Program Files AND in the registry, then reinstalled. did not resolve the issue. registry instructions from here: https://www.reddit.com/r/firefox/comments/s9lguc/how_to_completely_uninstall_firefox/

I have tried to delete existing profiles AND create a new profile but I always get an error: "An unexpected error has prevented your changes from being saved." https://support.mozilla.org/en-US/kb/profile-manager-create-remove-switch-firefox-profiles#w_start-the-profile-manager-when-firefox-is-closed

I'm out of things to try. Hate to abandon Firefox but I'm at the end of my capabilities.

Asked by list-a 3 hours ago

Firefox not playing some videos

Firefox does not play videos from this website: https://texassports.com/index.aspx. Only showing a black box. Edge and Chrome play the videos with no problem. This proble… (read more)

Firefox does not play videos from this website: https://texassports.com/index.aspx. Only showing a black box.

Edge and Chrome play the videos with no problem.

This problem exists on three different laptops, two W10s and one W7.

I am a long time user of Firefox and have never had this problem before.

What setting(s) do I need to change?

Asked by jack_b 3 hours ago

Ouvrir nouvel onglet; site non installé OVH Cloud

Lorsque je demande l'ouverture d'une nouvelle fenêtre, , puis d'un nouvel onglet, j'obtiens une fenêtre nommée nouvel onglet; puis en cliquant sur la croix + à droite j'… (read more)

Lorsque je demande l'ouverture d'une nouvelle fenêtre, , puis d'un nouvel onglet, j'obtiens une fenêtre nommée nouvel onglet; puis en cliquant sur la croix + à droite j'ai une fenêtre "site non installé OVH Cloud. Comment supprimer cette fenêtre?

Asked by daniel.grunspan 3 hours ago

Blank Website

Hi I am smith by profession a lawyer who handles various kinds of criminal cases in las vegas. The issue i want to raise is sometimes when I open my business website I … (read more)

Hi I am smith by profession a lawyer who handles various kinds of criminal cases in las vegas.


The issue i want to raise is sometimes when I open my business website I show white blank website. Just the scroller appear on the left side and nothing else. I also tried to open using VPN but the same thing goes on. First i thought i have serve issue but everything is Ok from server end. Then i realize it may the mozilla browser issue which i am using so i decided to contact you.

This is very serious issue for me please support team let me know the exact issue

I am using WIndow 8.1 64bit

Asked by smithjohny039 4 hours ago

Firefox 105 update corrupts places.sqlite

Auto-updated to v105 today (105.0.2 64-bit Windows 10) and all bookmarks were gone. Not just gone but the bookmark manager seems not to be rendering properly (see attache… (read more)

Auto-updated to v105 today (105.0.2 64-bit Windows 10) and all bookmarks were gone. Not just gone but the bookmark manager seems not to be rendering properly (see attached image where there should be at least some elements drawn). Additionally, neither the bookmarks nor history left pane show anything (second attachment).

The 105 update was applied this morning when first opening the browser. Profile folder -> bookmarkbackups shows a backup from just before the update. Bookmark library -> Restore gives that backup as an option, but restoring that backup has no effect (does nothing).

Exiting Firefox and manually moving places.sqlite to a backup location and then restarting also has no effect. places.sqlite is rebuilt but library -> restore still has no effect.

Asked by tikkoneus 5 hours ago

Last reply by tikkoneus 5 hours ago

Opening a Tweet in a new tab without switching to it

I just made the switch from Chrome to Firefox, and I'm still trying to understand the small differences that exist between the 2 browsers. While on Twitter, what I usuall… (read more)

I just made the switch from Chrome to Firefox, and I'm still trying to understand the small differences that exist between the 2 browsers.

While on Twitter, what I usually do is middle-click with my mouse on a Tweet to a new tab that I want to look into later, then continue scrolling down my timeline, then check out the Tweets I opened in the new tab(s). However, when I try to do the same thing on Firefox, it automatically opens the new tab. Because of how Twitter works, this also reloads the Home page when I opened it up, so I just lose anything I was just looking at when I opened the Tweet in a new tab.

What can I do differently here?

Asked by terriermon50 5 hours ago

Firefox instantly crashes

Hello my firefox instantly crashes whenever i try to open it and the crash message window pretty sure it is also closes instantly I dont think I litteraly cannot use the … (read more)

Hello my firefox instantly crashes whenever i try to open it and the crash message window pretty sure it is also closes instantly I dont think I litteraly cannot use the browser at all because of this. I am on a freshly reset pc aswell so i have no clue what it could be

Asked by isak.lothgren 5 hours ago

Last reply by isak.lothgren 5 hours ago

Twitch Error with Version 105.0.1

Recently updated to version 105.0.1 and I've started to have problems with Twitch. I'm unable to login and keep getting the message: "Something went wrong. Please try aga… (read more)

Recently updated to version 105.0.1 and I've started to have problems with Twitch. I'm unable to login and keep getting the message: "Something went wrong. Please try again." so I cleared the cookies/site data. Still unable to login. I know this isn't an error with my account as I can login via Chrome with no issues. Then I tried downgrading to the previous version 104.0.2 and had no issues with Twitch. Most likely, this new version is creating an error with the Twitch site. Hopefully new updates will address this issue - in the meantime, hoping someone has a solution.

Asked by Tychris 6 days ago

Last reply by Tychris 6 hours ago

Need to change background color of about:blank page

For years I've set the background display color in about:config to a medium gray, #CCCCCC. Main purpose was to change the background color of the about:blank page, which … (read more)

For years I've set the background display color in about:config to a medium gray, #CCCCCC. Main purpose was to change the background color of the about:blank page, which is my home page and my new tab page.

Note I am not overriding colors; #CCCCCC only showed up as the bgcolor for about:blank. Occasionally websites which forgot to specify a background color would show up with a medium gray background, a minor inconvenience and a hint their coding was not so great.

Just realized my background color selection for about:blank isn't working anymore. The background color of the about:blank page is white. Not sure when it changed. I failed to notice when the medium gray disappeared because I have been reflexively pressing the dim screen button. I have vision issues and need to avoid a white screen.

There was a question in 2021 about the about:blank page bgcolor turning white which was archived but does not look resolved.

https://support.mozilla.org/en-US/questions/1344438

Does about:blank now specify a bgcolor, overriding my about:config setting? I still have browser.display.background_color set to #CCCCCC. Do I need to change another value for about:blank now? Thanks for your help.

Using Firefox 105.0.1 64-bit on a Windows 10 Toshiba laptop.

Asked by CLARMAP 5 days ago

Last reply by CLARMAP 6 hours ago

Firefox do not open You-Tube-Videos

Hello, I use Firefox 105 on my PC. I have embedded various YouTube videos on my website. I've had the following problem for a few days: I can see my videos on both my s… (read more)

Hello, I use Firefox 105 on my PC. I have embedded various YouTube videos on my website. I've had the following problem for a few days: I can see my videos on both my smartphone and tablet without going to YouTube. On my PC (Win 10 Pro Vers. 21H2) the display wheel "rolls" without opening the video (... "an error has occurred, try again later"). But if I click on: "Watch on YouTube" plays the video via YouTube correctly. Does anyone have any idea what might be causing this? Is there a wrong setting in the Firefox browser? Many thanks and best regards Helmut

Asked by firefox2038 6 hours ago