Thunderbird not deleting drafts after autosave

Hello, This kind of problem is already asked and solved a lot, but sadly, I have an annoying variation of this kind of problem: Create/Write a new mail, let the windows o… (read more)

Hello,

This kind of problem is already asked and solved a lot, but sadly, I have an annoying variation of this kind of problem: Create/Write a new mail, let the windows open until it autosaves it as a draft and then send your mail. Problem is, that the autosaved mail is not deleted from drafts after sending.

Moving the drafts folder to local storage isn't an option.

Asked by MW - Chrom IT 2 weeks ago

Last reply by MW - Chrom IT 2 minutes ago

TB shows new items for imap account but I cannot subscribe the subfolders they are in

I have setup 8 imap accounts in TB and since the latest update I have a problem with one of them. For my arcor.de account the inbox section now frequently shows a little … (read more)

I have setup 8 imap accounts in TB and since the latest update I have a problem with one of them. For my arcor.de account the inbox section now frequently shows a little arrow with a number after the account if there are new messages. Alas I cannot see where these messages are if they are not in the inbox. From the web interface I found that they are mainly in the spam folder as my arcor account is the oldest one and it gets a lot of spam. I tried to subscribe to the spam folder of the arcor account but it is just not shown. This also applies to the other subfolders of the arcor account. I can tick them in the subscribe window but they do not get shown in the folder tree of the arcor account. I already renamed folderTree.json and restarted TB but that did not solve the problem. I really don't care about messages in the spam or other subfolders of the arcor account but the "new messages indicator" nags as it is too prominent. Is there a way to disable the subfolder check for the specific account? As a workaround I do a right click on the account and select "mark all folders read" but that is rather cumbersome in the long run.

Asked by ffsync5 22 minutes ago

Crashes

We've been using thunderbird for more than 20 years now at work. It has proven itself reliable and production ready. I am sorry to say in the last 5 years or so every up… (read more)

We've been using thunderbird for more than 20 years now at work. It has proven itself reliable and production ready. I am sorry to say in the last 5 years or so every update has been worse than the previous one becoming the least reliable piece of software ever. Constant crashing ie 8-10 times a day, lack of smtp communication with the servers, and other constant issues basically make this unusable.

PLEASE forget about aesthetics and concentrate on reliability.

Asked by nchrysanthou 2 days ago

Last reply by nchrysanthou 24 minutes ago

dualbooting: account's IMAP folder pruned on first installation, multiplies with .sbd suffix and inflated size on second installation

Hi, I dual boot Debian 11 and Windows 10 and have Thunderbird installed in each. I have never had problems with email discrepancies between the two installs. But today I … (read more)

Hi, I dual boot Debian 11 and Windows 10 and have Thunderbird installed in each. I have never had problems with email discrepancies between the two installs. But today I performed a major prune operation on the Debian installation, I deleted lots of mails and attachments that were taking up space. Sometimes I deleted the entire email, sometimes I kept the email but deleted the attachments from within the email-reading window. I did this both in inbox and sent.

You can see this account (underlined in red to the left in the image below). After the pruning/compacting the inbox was 326MB (down from 1.1 GB). I then booting Windows 10 and started Thunderbird whereupon syncing occurred to reflect my pruning. At this stage the number of emails in inbox and sent were the same in both Debian and Windows.

But when, after emptying trash and compacting folders in the Windows install, I go to wonder at all the saved hard drive space in Windows I notice that the account's corresponding folder seems the be two folders+subfolders instead of one (red underline). There are two inboxes, two sent, two of everything. One inbox file (green underline) matches exactly in size the size of the inbox on Debian, but the other one (green dotted) in hugely inflated. And searching the two inbox files (green underline/dotted) in the Windows install at random for emails still existing after the prune in my Debian inbox they show up in both of the Windows inbox files.

I see the same thing for another two accounts as well.

What is going on here?

/Peter

EDIT: adding image from windows install showing the size of the inbox in question from within TB. Corresponds with Debian size but raises questions about what the green dotted inbox actually is.

Asked by online23 11 hours ago

Thunderbird 91 Printing mails, images bigger as with Thunderbird 78

Hi mozilla, after updating Thunderbird to the latest version 91.2.1 we have noticed that images in printed mails are much bigger as they were with Thunderbird version 78… (read more)

Hi mozilla,

after updating Thunderbird to the latest version 91.2.1 we have noticed that images in printed mails are much bigger as they were with Thunderbird version 78. We are printing mails which contain orders from our webshop to ease the warehouse people the picking from the shelves. Changing the scaling will shrink the whole mail, so the text gets too small. With scaling set to a value around 50% the size of the pictures was as before. Is there a setting in print.printer which allows to change the scaling of images separately? Is there a list with available settings in print.printer ?

Many thanks for your reply in advance

Dieter

Asked by dieter-haas 43 minutes ago

translation problem resulting in multiple IMAP trash folders

Hello, In the attached picture, you will see three separate folders for deleted items: 1) "Gelöscht", where deleted items go when I use the the web interface of my provid… (read more)

Hello,

In the attached picture, you will see three separate folders for deleted items: 1) "Gelöscht", where deleted items go when I use the the web interface of my provider 2) "Papierkorb" where K9 Mail (on Android) puts deleted messages (which I can easily configure) 3) "Papierkorb", which is actually shown as "Trash" in K9 or the web interface and is Thunderbird's default folder.

It is my guess that there is no industry standard, which is a pity. I suggest that Thunderbird should at least show the real folder names. This way, I could try to configure all mail clients to use the same folder. A second suggestion, but this might be tough, is that Thunderbird could find out the pre-existing trash folder when adding an email account.

Best wishes,

Asked by Gaël Hammer 54 minutes ago

Thunderbird/Access 2007 SendObject Problem

Hi. I'm running win 10 (updated to most recent). I've recently rebuilt my computer and have reinstalled Access 2007 and a split database. In the front-end there is a scri… (read more)

Hi. I'm running win 10 (updated to most recent). I've recently rebuilt my computer and have reinstalled Access 2007 and a split database. In the front-end there is a script to email a text message to multiple recipients. I select the recipients from a list and click a "send" button, intending to send it as an email in Thunderbird. I'm using the standard Sendobject code. It used to work prior to the rebuild and now doesn't. The same database is used on another computer (both front-end and back-end are on a cloud drive) without problems. I get the message: "Runtime error 2046: The command or action SendObject isn't available now." The machine on which it works runs Access 2013. I have tried unsuccessfully tried running the database using the Access 2013 runtime engine. I vaguely remember that I had this problem before and I think that I needed to include a different object library within Access, but I’m really not sure if that was how I solved the problem. I have spent days looking for a solution. Can anyone help? Thanks in advance.

Asked by ggpotato 19 hours ago

Last reply by ggpotato 3 hours ago

display of emails I reply to

I completely hate the display emails when I reply. When Thunderbird changed to my reply being typed at the bottom of the email I did not like it. Now the reply shows the … (read more)

I completely hate the display emails when I reply. When Thunderbird changed to my reply being typed at the bottom of the email I did not like it. Now the reply shows the conversation out of order and marked by colored lines to link the order of conversation and the reply is at the bottom still. Hate it.

I can't believe anyone likes this change. If it's not changed. i'll have to find another email app, I stopped making donations after the last change I didn't like.

Russell G.

Asked by rgagliano 4 hours ago

trouble forwarding pdfs since thunderbird upgrade 91.2.1

Lots of email probs since this upgrade. Lost emails, errors sending out, cant save to drafts and this one. if i FORWARD an email that has a PDF attached, i get this ee… (read more)

Lots of email probs since this upgrade. Lost emails, errors sending out, cant save to drafts and this one.

if i FORWARD an email that has a PDF attached, i get this eerror ending of the message failed.

"There was an error attaching nameoffile.pdf Please check that you have access to the file." I have to save every pdf individually then attach. Even if I alrady attached it, if I try to resend to another address, i still get this error

Mac OS Mojave 10.14.6 TB 91.2.1

please help Thank you Lisa

Asked by lgriersales 8 hours ago

Cannot send emails. I get this when I try: An error occurred while sending mail: The mail server sent an incorrect greeting: "Cannot connect to SMTP server 64.59.128.135 (64.59.128.135:587) connect error 10060"

Cannot send emails. I get this when I try: "An error occurred while sending mail: The mail server sent an incorrect greeting: "Cannot connect to SMTP server 64.59.128.13… (read more)

Cannot send emails. I get this when I try: "An error occurred while sending mail: The mail server sent an incorrect greeting: "Cannot connect to SMTP server 64.59.128.135 (64.59.128.135:587) connect error 10060" Running Win7 I can receive emails okay.. Any suggestions would be appreciated.

Asked by Newbeak 3 days ago

Last reply by Newbeak 8 hours ago

91.2.0 upgrade: FILE_CORRUPTED address book empty / can't send email

I upgraded from 78.14 to 91.2.0 today. I am no longer able to Send email. My address book is also blank, but I continue to get auto-completion options when entering text… (read more)

I upgraded from 78.14 to 91.2.0 today. I am no longer able to Send email. My address book is also blank, but I continue to get auto-completion options when entering text into the "To" field. The error console displays the following when text is entered into the "To" field.

NS_ERROR_FILE_CORRUPTED: Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [mozIStorageService.openDatabase] SQLiteDirectory.jsm:43 NS_ERROR_FAILURE: 3 LDAPClient.jsm:255 [Exception... "Exception thrown by jsaddrbook://pab.na2: Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [mozIStorageService.openDatabase]" nsresult: "0x8052000b (NS_ERROR_FILE_CORRUPTED)" location: "JS frame :: resource:///modules/AbAutoCompleteSearch.jsm :: startSearch :: line 495" data: no] AbAutoCompleteSearch.jsm:495:13 NS_ERROR_FILE_CORRUPTED: Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [mozIStorageService.openDatabase] 2 SQLiteDirectory.jsm:43 NS_ERROR_FILE_CORRUPTED: Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [mozIStorageService.openDatabase] 2 SQLiteDirectory.jsm:43 Uncaught Exception { name: "NS_ERROR_FILE_CORRUPTED", message: "Component returned failure code: 0x8052000b (NS_ERROR_FILE_CORRUPTED) [mozIStorageService.openDatabase]", result: 2152857611, filename: "resource:///modules/SQLiteDirectory.jsm", lineNumber: 43, columnNumber: 0, data: null, stack: "openConnectionTo@resource:///modules/SQLiteDirectory.jsm:43:35\nget _dbConnection@resource:///modules/SQLiteDirectory.jsm:190:38\nget lists@resource:///modules/SQLiteDirectory.jsm:208:27\ngetMailListFromName@resource:///modules/AddrBookDirectory.jsm:375:22\nhasMailListWithName@resource:///modules/AddrBookDirectory.jsm:420:17\nmailListNameExists@resource:///modules/AddrBookManager.jsm:511:15\nupdateSendLock@chrome://messenger/content/messengercompose/MsgComposeCommands.js:5023:25\nupdateSendCommands@chrome://messenger/content/messengercompose/MsgComposeCommands.js:2040:3\nonRecipientsChanged@chrome://messenger/content/messengercompose/MsgComposeCommands.js:5745:21\nrecipientAddPills@chrome://messenger/content/messengercompose/addressingWidgetOverlay.js:964:5\nobserve@chrome://messenger/content/messengercompose/MsgComposeCommands.js:252:24\nhandleEnter@chrome://global/content/elements/autocomplete-input.js:584:31\nhandleKeyDown@chrome://global/content/elements/autocomplete-input.js:549:25\nAutocompleteInput/<@chrome://global/content/elements/autocomplete-input.js:40:54\n", location: XPCWrappedNative_NoHelper }

After an address and subject and content are entered, clicking the Send button has no effect, in the application or the error console. I've seen other posts about send and address book issues with 91.2, but their error messages are different from what I'm seeing. Thank you!

Asked by Lee 1 week ago

Last reply by Lee 8 hours ago

thunderbird email does not recognize my password. it says password failed to send. i cannot get or send mail

thunderbird does not recognize my password. i cannot get or send messages. others seem to have this problem but I see no answers. it says the password failed to send. … (read more)

thunderbird does not recognize my password. i cannot get or send messages. others seem to have this problem but I see no answers. it says the password failed to send. the last mail I got was at the end of september. then it spontaneously stopped working. if there is a solution, please be specific about the steps, as I am not particularly adept with this stuff. thank you

Asked by magbarnaby 8 hours ago

How do I hide the 'Junk' button?

As the subject suggests, how do I hide the 'Junk' button in Thunderbird? Some 'help' articles have suggested that I simply use the "Customize Toolbar" menu (right-click t… (read more)

As the subject suggests, how do I hide the 'Junk' button in Thunderbird?

Some 'help' articles have suggested that I simply use the "Customize Toolbar" menu (right-click the toolbar-->Customize...), but that menu won't allow me to drag (remove) the 'Junk' button away from the toolbar (it actually won't allow me to drag any button away from this particular part of the screen).

I am using Thunderbird 78.13.0 - the latest 'stable' release in Ubuntu 20.04 LTS ("Focal Fossa") at the time of writing - installed as a traditional 'Debian' package via APT (the default 'Snap' version doesn't print background colors / images in e-mail messages).

Any help would be appreciated.

Asked by gregory7 11 hours ago

Upgrade to 91.2.0 (32 bit) adds long string of unnecessary information to filename when saving an email.

Ever since automatically upgrading to 91.2.0 when I save an email Thunderbird adds a lengthy string of data to the end of the filename which causes me great difficulty. … (read more)

Ever since automatically upgrading to 91.2.0 when I save an email Thunderbird adds a lengthy string of data to the end of the filename which causes me great difficulty. Here is an example from an email from the NYTimes: "Today's Headlines Key to Biden’s Climate Agenda Likely to Be Cut Because of Manchin Opposition" is the filename. Thunderbird automatically adds the following to it. " - The New York Times (nytdirect@nytimes.com) - 2021-10-16 0101"

This information lengthens the filename which I have to delete because it messes up my archive where I save numerous emails. Therefore I have to delete it every time I save an email (60 or more times every day) and interferes with any search I conduct of those saved emails.

I have explored all the options under Tools and Help to no avail. Can you please tell me how I can get rid of this annoyance. It is causing me lost time in my daily work creating an archive of articles. I've been working on this archive for nearly 18 years and this problem is causing me a great deal of grief and lost work time. Thank you.

Asked by gruff 1 week ago

Last reply by gruff 11 hours ago

IMAP Local sync not loading messages sent or moved after initial sync

For legal reasons, I need to retain a copy locally of all my messages since my mailhost was purchased by another company and they now limit us to 1 GB per email address. … (read more)

For legal reasons, I need to retain a copy locally of all my messages since my mailhost was purchased by another company and they now limit us to 1 GB per email address. Previously I didn't worry about it as there were no limits on mail storage space. I've thoroughly gone through the article on synchronizing messages on the server with messages stored locally on my machine. I cannot get Thunderbird to behave the way it is described in the article. I've tried both checking the box to store all messages locally and the advanced method of selecting folders (and I select everything except spam and junk). The only thing stored locally is what was stored when I initially copied the Inbox (on the server) to Local. All of that synced properly Any changes such as new messages, messages moved to different folders, etc. do not appear in Local. I have tried closing and reopening Thunderbird in hopes that it will work like the article states, that Thunderbird will check the server for changes and save them locally. Alas, it does not.

Did I incorrectly set this up? Do I need to initiate some kind of copy of new or moved to another folder emails? Or something else? I'm reasonably software savvy but this one is eluding me. I am urgently looking for a solution since my mailhost is pressuring me to pay large sums to retain my emails. Thanks very much for any solutions or suggestions

Asked by user219 5 days ago

Last reply by user219 13 hours ago

just upgraded and have a few issues

I just upgraded to version 91 from a very old Thunderbird version. All folders and messages came across just fine. But I have three issues 1. There is now nothing in m… (read more)

I just upgraded to version 91 from a very old Thunderbird version. All folders and messages came across just fine. But I have three issues 1. There is now nothing in my address book. What location are all my old contacts? 2. In the latest version, I am having to input my email passwords each time for each account. How to I get Tbird to retain them? 3. I have 3000 messages in a local pop folder. Is there any way to get them into IMAP in Gmail. Dragging and dropping a few at a time is hopeless Thanks for your help David

Asked by david533 14 hours ago

Need help finding Request body

I am having trouble SMTP, and the support agent for my service needs the full request body or JSON payload from Thunderbird to their servers. Is there a way to find that… (read more)

I am having trouble SMTP, and the support agent for my service needs the full request body or JSON payload from Thunderbird to their servers.

Is there a way to find that information. I have found full headers, but cannot find any info on location of JSON payloads, or if they are something I have access to?

Asked by ckelly1 14 hours ago

Thunderbird will not start, do not understand error message

I'm using Thunderbird 64-bit for Linux, the latest version in the Ubuntu repositories for 20.2 LTS. Thunderbird was running fine when I shut the PC down last night, this … (read more)

I'm using Thunderbird 64-bit for Linux, the latest version in the Ubuntu repositories for 20.2 LTS. Thunderbird was running fine when I shut the PC down last night, this morning I couldn't get it to start, and running

thunderbird %u

in a terminal produced the output below. This is over my head, I'm afraid. Can anybody tell me what I need to do to fix the problem? I have made no changes to the PC (no upgrades) since Thunderbird was working OK last night.

Thanks!


[calBackendLoader] Using Thunderbird's libical backend JavaScript error: resource://gre/modules/MessengerContentHandler.jsm, line 75: NS_ERROR_FAILURE: Extension error: Error while loading 'jar:file:///usr/lib/thunderbird/extensions/messagingmenu@mozilla.com.xpi!/manifest.json' (NS_ERROR_FILE_NOT_FOUND) resource://gre/modules/Extension.jsm:570 :: readJSON/</<@resource://gre/modules/Extension.jsm:570:20 onStopRequest@resource://gre/modules/NetUtil.jsm:128:18 observe@resource://gre/modules/AsyncShutdown.jsm:554:16 </p>

Extension error: Error while loading 'jar:file:///usr/lib/thunderbird/omni.ja!/chrome/messenger/search-extensions/twitter/manifest.json' (NS_ERROR_FILE_NOT_FOUND) resource://gre/modules/Extension.jsm:570 :: readJSON/</<@resource://gre/modules/Extension.jsm:570:20 onStopRequest@resource://gre/modules/NetUtil.jsm:128:18 observe@resource://gre/modules/AsyncShutdown.jsm:554:16 </p>

JavaScript error: resource://gre/modules/ConduitsChild.jsm, line 179: Error: CallResult for closed conduit {2ab1b709-ba03-4361-abf9-c50b964ff75d}.24: ({childId:"{2ab1b709-ba03-4361-abf9-c50b964ff75d}.24", callId:55, path:"extensionScripts.register", result:{}}) JavaScript error: resource://gre/modules/ConduitsChild.jsm, line 179: Error: CallResult for closed conduit {2ab1b709-ba03-4361-abf9-c50b964ff75d}.24: ({childId:"{2ab1b709-ba03-4361-abf9-c50b964ff75d}.24", callId:45, path:"menus.remove", result:{}}) JavaScript error: resource://gre/modules/JSONFile.jsm, line 173: Error: Data is not ready.

      1. !!! [Parent][DispatchAsyncMessage] Error: PBackground::Msg_PBackgroundIDBFactoryConstructor Value error: message was deserialized, but contained an illegal value

Asked by brian_m 1 day ago

Last reply by brian_m 14 hours ago