Mozilla サポートの検索

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

このスレッドはアーカイブに保管されました。 必要であれば新たに質問してください。

Cant find text option under Firefox -> Preferences -> Applications

  • 4 件の返信
  • 2 人がこの問題に困っています
  • 69 回表示
  • 最後の返信者: subashini.rajan

more options

Hi,

I've been trying to automatically save "text/csv" files to the download folder. I did not want to see the "Opening xxx.csv" prompt which had "Open With" and "Save to" options. I wanted to avoid this prompt and just save the files directly to download directory and not open them once download completed. I'm running selenium tests to download the files and i'd be more interested to know about any user_pref options i could use to achieve this.

I tried using user_pref("browser.helperApps.neverAsk.saveToDisk","text/csv,text") in the prefs.js file in the firefox profile directory, but the prompt still shows up. Appreciate some help!

Thanks, Subashini

Hi, I've been trying to automatically save "text/csv" files to the download folder. I did not want to see the "Opening xxx.csv" prompt which had "Open With" and "Save to" options. I wanted to avoid this prompt and just save the files directly to download directory and not open them once download completed. I'm running selenium tests to download the files and i'd be more interested to know about any user_pref options i could use to achieve this. I tried using user_pref("browser.helperApps.neverAsk.saveToDisk","text/csv,text") in the prefs.js file in the firefox profile directory, but the prompt still shows up. Appreciate some help! Thanks, Subashini

選ばれた解決策

You can only set an automatic download action for a specific MIME type, so if this isn't working then you need to check how the servers sends the csv files and possibly configure the server correctly if you have access.

この回答をすべて読む 👍 1

すべての返信 (4)

more options

Maybe the following add-on can do what you need:

Export-to-csv

more options

@smo.. thanks for the response.. the Export-to-csv plugin says its for exporting HTML table data as CSV file. But i already have a link to the csv, i just want it downloaded to the the download directory when i click the link, I was able to do this in chrome, but not sure how to enable the user preferences to do this.

Thanks, Subashini

more options

選ばれた解決策

You can only set an automatic download action for a specific MIME type, so if this isn't working then you need to check how the servers sends the csv files and possibly configure the server correctly if you have access.

more options

@cor-el Appreciate your help! I think this would solve the issue.The MIME type for the file was "application/octet-stream". I tried setting the MIME type to "text/csv" locally and was able to save the files without the prompt. Thanks Again! Subashini