Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

New Issue - Unable to send email from one of two accounts - both Comcast

  • 12 replies
  • 0 have this problem
  • 36 views
  • Last reply by sammler317

more options

We have used Thunderbird for 20+ years, and have had no problems until the latest update yesterday. Now, we can only send e-mail from one of the 2 Comcast accounts for which we are using Thunderbird. If we try sending from the other account, the following error message shows up: "Sending of the message failed. An error occurred while sending mail. The mail server responded: Please ensure your email address and authenticating user match when sending messages. Please verify that your email address is correct in your account settings and try again." I have gone through all settings, and noticed that, for both "identities", the server is configured to use the same user name, when the other email account has a different email address. I have tried editing the server settings, adding a new identity, and no luck. Very frustrating. Again, this started yesterday after Thunderbird performed an update.

We have used Thunderbird for 20+ years, and have had no problems until the latest update yesterday. Now, we can only send e-mail from one of the 2 Comcast accounts for which we are using Thunderbird. If we try sending from the other account, the following error message shows up: '''''"''Sending of the message failed. An error occurred while sending mail. The mail server responded: Please ensure your email address and authenticating user match when sending messages. Please verify that your email address is correct in your account settings and try again.''" '''''I have gone through all settings, and noticed that, for both "identities", the server is configured to use the same user name, when the other email account has a different email address. I have tried editing the server settings, adding a new identity, and no luck. Very frustrating. Again, this started yesterday after Thunderbird performed an update.

Chosen solution

Looking at your screenshots, you are attacking the wrong problem: Scroll down to the bottom of that list on the left, to where you see "Outgoing Server (SMTP)". Click on it. You should now see on the right "Outgoing Server (SMTP) Settings" and a list box below that. You need two entries in that box. One for Comcast and one for Molly. Click on "Add" to create a second server if it is not already there. Best to give them name them as David suggested. The two entries will have the same SMTP server name (mail.comcast.com) and port number, SSL/TLS. But each should have its own User Name. When the two SMTP servers are setup, one for Comcast and one for Molly, go back to the Account, Server Settings in the left hand menu, and select the Molly server for Molly and the Comcast server for Comcast. TB will likely ask for for at least one of the passwords again when you try to send.

Read this answer in context 👍 0

All Replies (12)

more options

Be sure to check that, for the two accounts you have two incoming servers defined and two smtp servers defined. Verify also that each account identifies with the proper smtp server. Screenshots of both smtp server setups will be useful.

more options

HI David,

Thanks for your quick response. Here is the info you requested. I only included one of the SMTP server setup windows, since they are the same. I believe that is the problem. One of them should have sammler317 as a user name, but Thunderbird will not allow it. If I make a change, it changes both accounts.

more options

What you're saying is that you have defined the problem, but since you don't have a solution, I encourage you to consider other possibilities. What you have is something amiss among your server definitions. I suggest first to get each smtp server a unique description (not comcast email server) so it's easier to differentiate between them, and to do screenshots of both incoming server settings and both smtp server settings. Why is the username for incoming sammler317 and the username for smtp an email address? I'm not saying that's wrong, but it's confusing.

more options

Hi David,

There are 2 email accounts Comcast Mail (sammler317) and Molly Business Mail (mhsesq). The SMTP screenshot I sent is, for some reason, the same for both accounts. If I change the username to sammler317, regardless of which account I am in when it is changed, I can only send email from the Comcast mail account, but not the Molly Business Mail (mhsesq) account. If I change the SMTP to mhsesq@comcast.net, I can only send from that account. I have no clue what the settings were before yesterday, since I have used Thunderbird without issue for so long, it never seemed necessary. Not sure if this helps clarify the issue.

more options

Sending the screenshots would help.

more options

What additional screenshots, other than those I sent in my original reply to you, do you need? Thanks.

Bill S.

more options

Seeing all four would help. That ensure you and anyone here will be seeing the same thing.

more options

Hi David,

Happy Thanksgiving!! I was out of town for a few days, and unable to respond to your last reply. Here is an image that contains all 4 of the server settings you requested. Please note, in the SMTP settings as they are, I cannot send email from Comcast Email. If I change the setting to use the sammler317 email address, I can only send from Comcast email, and not Molly Business Mail. Hope this helps.

more options

Some suggestions (that may do nothing, but I encourage doing): - give the two SMTP servers different names. Otherwise you cannot be sure to which you link the accounts. You have them both named 'comcast email servers' - I think this is part of your problem. - try setting sammler17 to sammler17@comcast.net - once you have renamed the SMTP servers, set the sammler email id to that one.

more options

Hi David,

Thank you for your response. I have tried that already, and it didn't help the problem. IMO, this was a build that somehow altered the settings which had worked for nearly 20 years, and I am at a loss as to how to successfully return things to their original state.

more options

Chosen Solution

Looking at your screenshots, you are attacking the wrong problem: Scroll down to the bottom of that list on the left, to where you see "Outgoing Server (SMTP)". Click on it. You should now see on the right "Outgoing Server (SMTP) Settings" and a list box below that. You need two entries in that box. One for Comcast and one for Molly. Click on "Add" to create a second server if it is not already there. Best to give them name them as David suggested. The two entries will have the same SMTP server name (mail.comcast.com) and port number, SSL/TLS. But each should have its own User Name. When the two SMTP servers are setup, one for Comcast and one for Molly, go back to the Account, Server Settings in the left hand menu, and select the Molly server for Molly and the Comcast server for Comcast. TB will likely ask for for at least one of the passwords again when you try to send.

more options

Geoff,

Thank you so much for your help. This resolved the issue. David, if Geoff's explanation is what you were suggesting I do, I apologize for being dense. I never looked at the Outgoing SMTP Server link at the bottom left of the TB screen, so I never attempted to add the second server. Thank you both again for your help!!!