Przeszukaj pomoc

Unikaj oszustw związanych z pomocą.Nigdy nie będziemy prosić Cię o dzwonienie na numer telefonu, wysyłanie SMS-ów ani o udostępnianie danych osobowych. Zgłoś podejrzaną aktywność, korzystając z opcji „Zgłoś nadużycie”.

Learn More

WordPress Embedded Google Sheets not working in Firefox only

  • 3 odpowiedzi
  • 3 osoby mają ten problem
  • 133 wyświetlenia
  • Ostatnia odpowiedź od cor-el

more options

I have some embedded Google Sheets on my WordPress website. They display fine in Safari and Chrome, but recently have stopped working in Firefox. They used to work fine in Firefox, as the website was designed in Firefox, as it is my preferred browser.

Attached is a screenshot showing a webpage with 2 embedded Google Sheets in 3 separate browsers.

Here is the HTML embedded source: <iframe width="800" height="376" src="https://docs.google.com/spreadsheets/d/1PRC5Ofes2f11D2WgjEzvJqQfigYpGLzklJUdF3n1oSc/pubchart?oid=1658726112&format=interactive" frameborder="0"></iframe>

Client software: macOS Sierra 10.12.4, Firefox 53.0 (64-bit), Google Chrome 58.0.3029.81 (64-bit), Safari 10.1

Server software: WordPress 4.7.4

I have some embedded Google Sheets on my WordPress website. They display fine in Safari and Chrome, but recently have stopped working in Firefox. They used to work fine in Firefox, as the website was designed in Firefox, as it is my preferred browser. Attached is a screenshot showing a webpage with 2 embedded Google Sheets in 3 separate browsers. Here is the HTML embedded source: <iframe width="800" height="376" src="https://docs.google.com/spreadsheets/d/1PRC5Ofes2f11D2WgjEzvJqQfigYpGLzklJUdF3n1oSc/pubchart?oid=1658726112&amp;format=interactive" frameborder="0"></iframe> Client software: macOS Sierra 10.12.4, Firefox 53.0 (64-bit), Google Chrome 58.0.3029.81 (64-bit), Safari 10.1 Server software: WordPress 4.7.4
Załączone zrzuty ekranu

Zmodyfikowany przez occorled w dniu

Wybrane rozwiązanie

Note that this is a SVG image.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Firefox/Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Firefox/Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button# or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.

Przeczytaj tę odpowiedź w całym kontekście 👍 2

Wszystkie odpowiedzi (3)

more options
more options

I don't think those plugins are needed to view an iframe embedded Google Sheet chart.

Also, I noticed that some sites are supporting the most up-to-date Firefox on Windows, but not macOS. For example, Bank of America: https://www.bankofamerica.com/information/supported-browsers/

Do you think there are differences in functionality that would cause this?

Actually, I forgot I have a Windows VM...

OK, I've confirmed this works on: Windows 7, Firefox v53.0 (32-bit) But I still have the problem on: macOS Sierra, Firefox v53.0 (64-bit)

more options

Wybrane rozwiązanie

Note that this is a SVG image.

You can try these steps in case of issues with web pages:

You can reload web page(s) and bypass the cache to refresh possibly outdated or corrupted files.

  • hold down the Shift key and left-click the Reload button
  • press "Ctrl + F5" or press "Ctrl + Shift + R" (Windows,Linux)
  • press "Command + Shift + R" (Mac)

Clear the cache and remove the cookies from websites that cause problems via the "3-bar" Firefox menu button (Options/Preferences).

"Clear the cache":

  • Firefox/Options/Preferences -> Advanced -> Network -> Cached Web Content: "Clear Now"

"Remove the cookies" from websites that cause problems.

  • Firefox/Options/Preferences -> Privacy -> "Use custom settings for history" -> Cookies: "Show Cookies"

Start Firefox in Safe Mode to check if one of the extensions ("3-bar" menu button# or Tools -> Add-ons -> Extensions) or if hardware acceleration is causing the problem.