Iskanje po podpori

Izogibajte se prevarantski tehnični podpori. Nikoli vam ne bomo naročili, da pokličete telefonsko številko ali nam pošljete osebne podatke. Sumljivo dejavnost prijavite z gumbom »Prijavi zlorabo«.

Learn More

Inserting link into e-mail always shows URL

  • 4 odgovori
  • 1 ima to težavo
  • 244 ogledov
  • Zadnji odgovor od becomingandy

more options

I'm using Thunderbird 78.8.1 (64-bit) on a Mac.

When I write an e-mail and want to insert a hyperlink, I highlight the word I want the e-mail recipient to see hyperlinked, type command-K, and enter in the URL I want that word hyperlinked to. After doing so, on my end, the word is underlined, highlighted in blue and appears to be hyperlinked in the message. However, when the e-mail gets to the recipient's inbox, the entire URL that I hyperlinked is visible in brackets next to word that I had tried to embed the link in. I cannot figure out how to have the recipient see just the hyperlinked word, and not the entire URL.

Thank you for any help!

I'm using Thunderbird 78.8.1 (64-bit) on a Mac. When I write an e-mail and want to insert a hyperlink, I highlight the word I want the e-mail recipient to see hyperlinked, type command-K, and enter in the URL I want that word hyperlinked to. After doing so, on my end, the word is underlined, highlighted in blue and appears to be hyperlinked in the message. However, when the e-mail gets to the recipient's inbox, the entire URL that I hyperlinked is visible in brackets next to word that I had tried to embed the link in. I cannot figure out how to have the recipient see just the hyperlinked word, and not the entire URL. Thank you for any help!

Izbrana rešitev

In Preferences/Composition/HTML Style, Send Options..., what do you have for Text format? If it's not 'Send the message in HTML anyway', change it to that and see if it makes a difference.

Check also that when you enter a URL in the Link Location box, it's the complete syntax, such as:

https://support.mozilla.org/en-US/questions/1329019

not just e.g. www.example.org

Preberite ta odgovor v kontekstu 👍 0

Vsi odgovori (4)

more options

How is the recipient viewing email? If their setting is for plain text only, an html-formatted link, like the one you send, might appear 'separated'. The equivalent setting in TB is View/Message Body As.

more options

Thank you for the reply!

I've had several people view my e-mails using different e-mail platforms including Gmail, Outlook and Thunderbird and it's all the same result. The URL always show.

In my Thunderbird, for example, when I go to "View - Message Body As", it is set to "Original HTML" and I still have this problem (I've run tests where I e-mail myself to confirm the problem is persisting). Changing the view to "Simple HTML" doesn't solve the problem either.

Thank you again for replying.

more options

Izbrana rešitev

In Preferences/Composition/HTML Style, Send Options..., what do you have for Text format? If it's not 'Send the message in HTML anyway', change it to that and see if it makes a difference.

Check also that when you enter a URL in the Link Location box, it's the complete syntax, such as:

https://support.mozilla.org/en-US/questions/1329019

not just e.g. www.example.org

more options

Thank you so much! This solved the problem! I've been trying to solve this for months and am so grateful!