搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

all files as default instead of all supported files

more options

Is there any way to change the default from all supported files to all files while trying to select a file? With all supported files JPG, PNG files are not shown. You have to manually change it to all files for those files to be displayed. In Edge browser it is showing "all files" by default.

Vijay.

Is there any way to change the default from all supported files to all files while trying to select a file? With all supported files JPG, PNG files are not shown. You have to manually change it to all files for those files to be displayed. In Edge browser it is showing "all files" by default. Vijay.
已附加屏幕截图

所有回复 (5)

more options

So what site are you at that is doing this?

more options

That is a question for Windows 10 support, as that File Upload window is part of the Windows Operating System.

more options

Hi Vijay, different sites may vary, so let's take this site as an example.

When you click the Browse button used to attach an image on this site, Firefox applies an All Supported Types filter showing specific file extensions:

The reason is the file input is coded to filter the types of files that can be uploaded just to JPEG, PNG, and GIF files:

<input type="file" id="id_image" name="image" size="30" accept="image/jpeg,image/png,image/gif" title="Browse for an image to upload.">

If you use the Page Inspector tool to change that to

<input type="file" id="id_image" name="image" size="30" accept="*/*" title="Browse for an image to upload.">

Then Firefox will trigger Windows to show All Files (*.*), without listing the other filters:

Now, back to Zoho.

In your screenshot, the dialog seems to be stuck somewhere in between, which could be due to some unusual code in the page. Could you check with Zoho support to get their views?

more options

Will check with them. The reason I didnt contact them was because it was working alright in Edge browser.

more options

It's a Windows thing; try saving a screenshot in Paint.

Probably has to do with "Hiding Known File Extensions." A picture.jpg winds up being a picture.jpg.jpeg, but the .jpeg gets hidden because .jpg is a recognized file type, and everything after gets cut off.

Are you right-clicking and "Save Image As...?" "Save Image" automatically selects the folder depending on file type; .PNG and .GIF get saved to Downloads, while .JPG gets saved to Pictures.