搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Subfolders don't highlight on new messages if parent folder is not expanded (dark theme)

  • 11 个回答
  • 2 人有此问题
  • 63 次查看
  • 最后回复者为 Toad-Hall

more options

Using Dark Theme

As of version 91 (currently running 91.2.0, build 20211004152603), parent folders highlight (bold and colored blue) when a new message arrives in it or any of the subfolders inside it. If the parent folder is expanded when the email arrives, the subfolder will also highlight. If the parent folder is closed when the new mail arrives, the subfolder will not be bold or colored when the parent folder is expanded. If I click on the subfolder, it will show up bold, but not colored.

For example, parent folder not expanded, currently 1 unread message in subfolder B: parent folder (1) - bold. Shows unread msg count for this and all subfolders

Expanding parent folder shows: parent folder - No message count (expected, since individual subfolders show message count), not bold or colored -> subfolder A -> subfolder B (1) - currently has unread message. Shows as bold, but not colored

With parent folder collapsed, new message arrives in subfolder A. Parent folder now shows unread message count for tree, and is bold and colored. parent folder (2) - bold. Shows unread msg count for this and all subfolders

Expanding parent folder shows: parent folder - No message count (expected, since individual subfolders show message count), not bold or colored -> subfolder A (1) - unread message count shows in parens, but *not colored or bold* -> subfolder B (1) - still bold, not colored

With parent folder expanded, new message arrives in subfolder A. parent folder - No message count (expected, since individual subfolders show message count), not bold or colored -> subfolder A (1) - highlighted (colored and bold), unread message count shows in parens -> subfolder B (1) - still bold, not colored

Using Dark Theme As of version 91 (currently running 91.2.0, build 20211004152603), parent folders highlight (bold and colored blue) when a new message arrives in it or any of the subfolders inside it. If the parent folder is expanded when the email arrives, the subfolder will also highlight. If the parent folder is closed when the new mail arrives, the subfolder will not be bold or colored when the parent folder is expanded. If I click on the subfolder, it will show up bold, but not colored. For example, parent folder not expanded, currently 1 unread message in subfolder B: parent folder (1) - bold. Shows unread msg count for this and all subfolders Expanding parent folder shows: parent folder - No message count (expected, since individual subfolders show message count), not bold or colored -> subfolder A -> subfolder B (1) - currently has unread message. Shows as bold, but not colored With parent folder collapsed, new message arrives in subfolder A. Parent folder now shows unread message count for tree, and is bold and colored. parent folder (2) - bold. Shows unread msg count for this and all subfolders Expanding parent folder shows: parent folder - No message count (expected, since individual subfolders show message count), not bold or colored -> subfolder A (1) - unread message count shows in parens, but *not colored or bold* -> subfolder B (1) - still bold, not colored With parent folder expanded, new message arrives in subfolder A. parent folder - No message count (expected, since individual subfolders show message count), not bold or colored -> subfolder A (1) - highlighted (colored and bold), unread message count shows in parens -> subfolder B (1) - still bold, not colored

所有回复 (11)

more options

I have the same problem. I'm using the light theme, but the theme has no bearing on this problem.

It is quite frustrating, as I have many subfolders, and it's impossible to tell which subfolder contains the message(s) just received.

For a 1-minute video demonstrating this problem, see https://youtu.be/1-V18dvN4lc

more options

Having the same issue here. I am thinking about downgrading to 78.14.0 in the meantime.. very very annoying regression bug. How do we gain some tractions here?

more options

Looks like it's fixed in 91.3.0, although I didn't see anything specifically related in the release notes.

more options

Hi, I have the same problem. I upgrade thunderbird to 91.3.0 but not work! Max

more options

I thought it was fixed in 91.3.0, but it only worked correctly the first time after restart. I confirmed this by restarting Thunderbird, and it worked correctly again.

Also - not stated in the original message, this is on MacOS.

more options

Old Coot on a Bike As Per video Top level folder - Bret Sorted - is Blue and star highlight indicating new unread mail since last opened - ok When it is selected to open and see subs - the highlight and star is gone - this is correct

Sub folder 'clubs / organisation' folder - is Blue and star highlight - indicating new unread mail since last opened - ok When it is select to open and see subs that highlight and star is gone - this is correct

The sub sub folder are only Bold to suggest contains old unread messages - wrong in the case of one folder called Sass - but I expect the emails were auto filtered to the Sass folder.

Select 'Sass' sub sub folder - now gets star - weird and wrong - it should already have that star but is still not Blue at the start before selecting - wrong as well. Although now you have selected it, it should be just bold, so in that part it is correct, but the star should have gone when selected not appear. Then star also goes after closing - this is correct because you have selected that folder and therefore no longer contains new since last opened.


In my case, filtered emails go to folder and folder is just bold as if unread mail even though I know it has just received a new mail. Selecting folder does not get star highlight as in my case. It's not a sub folder. But the common theme in your case and mine is the emails were filtered and the receiving folder is not highlighted blue and no star.

I'm trying to identify exactly which part is wrong before reporting as a bug.

I also find that for emails that get filtered - the pop up notication shows no content. Annoying.

more options

Old Coot on a Bike and massimo11 What Operating System are you using ?

bvitro Which MAC OS ?

PS, it would seem I've got one folder being awkward, all others work as expected. Currently running tests on subfolder - so would appreciate some reports.

more options

MacOS 12.0.1, but I just upgraded, and it happened with the previous MacOS version as well.

more options

@Toad-Hall: I'm running Windows 10 Pro.

more options

Ditto! I have a ton of folders and filters to distribute messages based on the sender. The main folder shows up highlighted, however any subfolders under it just show up an anemic little (n) on the end, with a bunch of folders it's much harder to find the place the new message just went. This worked up to a few weeks ago.

I'm currently on 91.7.0, which is up to the minute, so this is not fixed yet! I am running Windows 10 Home.

more options

Located a bug report, so I'm providing information so it can be followed: https://bugzilla.mozilla.org/show_bug.cgi?id=1734192