搜索 | 用户支持

防范以用户支持为名的诈骗。我们绝对不会要求您拨打电话或发送短信,及提供任何个人信息。请使用“举报滥用”选项报告涉及违规的行为。

Learn More

Why can't I drag and drop bookmarks?

  • 16 个回答
  • 22 人有此问题
  • 452 次查看
  • 最后回复者为 BevHoward

more options

When I highlight the URL in the location bar and try to drag and drop it to a folder in the book mark bar or to anywhere else all that happens is a circle with a slash across it. It's impossible to drag and drop a url to create a bookmark.

I can find nothing in the Options to correct this deficiency.

When I highlight the URL in the location bar and try to drag and drop it to a folder in the book mark bar or to anywhere else all that happens is a circle with a slash across it. It's impossible to drag and drop a url to create a bookmark. I can find nothing in the Options to correct this deficiency.

被采纳的解决方案

Thanks... didn't see a "closed" flag.

Favicons was one of the first things I uninstalled

wilco

在上下文中阅读这个答案 👍 0

所有回复 (16)

more options

Does it work any better to drag the padlock or globe icon to the Bookmarks Toolbar?

To see whether the problem is caused by one of your extensions, could you repeat the test in Firefox's Safe Mode? That's a standard diagnostic tool to bypass interference by extensions (and some custom settings). More info: Diagnose Firefox issues using Troubleshoot Mode.

You can restart Firefox in Safe Mode using

Help > Restart with Add-ons Disabled

In the dialog, click "Start in Safe Mode" (not Reset)

Any difference?

more options

Do you still have bookmarks on the Bookmarks Toolbar?

Start Firefox in Safe Mode to check if one of the extensions (Firefox/Tools > Add-ons > Extensions) or if hardware acceleration is causing the problem (switch to the DEFAULT theme: Firefox/Tools > Add-ons > Appearance).

  • Do NOT click the Reset button on the Safe Mode start window.

Make sure that toolbars like the "Navigation Toolbar" and the "Bookmarks Toolbar" are visible.

  • Firefox menu button > Options
  • View > Toolbars (press F10 to display the hidden Menu bar)
  • Right-click empty toolbar area

Use Toolbar Layout (Customize) to open the Customize window and set which toolbar items to display.

  • check that "Bookmarks Toolbar items" is on the Bookmarks Toolbar
  • if "Bookmarks Toolbar items" is not on the Bookmarks Toolbar then drag it back from the toolbar palette into the Customize window to the Bookmarks Toolbar
  • if missing items are in the toolbar palette then drag them back from the Customize window on the toolbar
  • if you do not see an item on a toolbar and in the toolbar palette then click the "Restore Default Set" button to restore the default toolbar setup
more options

I just remembered something that I turned off.

By default, Firefox tries to reduce clutter on the address bar by hiding the http:// from the beginning of the address. This does not occur on secure sites; there you will see the https://. And you will notice that if you select and drag the address to the Bookmarks Toolbar it works on the secure sites but not on the regular ones.

Aha! It seems that is not a coincidence. If you don't mind or would prefer to have the http:// back, you can turn off the hiding.

(1) In a new tab, type or paste about:config in the address bar and press Enter. Click the button promising to be careful.

(2) In the search box above the list, type or paste urlb and pause while the list is filtered

(3) Double-click the browser.urlbar.trimURLs preference to switch it from true to false.

more options

Thank you Jscher2000, that answered my question. All I have ever had to do in other browsers was to click in the address bar and highlight the URL then hold the mouse button down and drag it to a folder. I used to do this in previous versions of Firefox too. I never thought of having to drag the "globe" instead of the highlighted URL. However on this page it works as I have always used it. Maybe that is because it's a https: URL. Again, thanks for the quick response!

more options

It works in safe mode so how do i find out which add on is causing my problem?

more options

Try to disable hardware acceleration in Firefox (you need to close and restart Firefox).

  • Tools > Options > Advanced > General > Browsing: "Use hardware acceleration when available"

If it works in Safe Mode and in normal mode with all extensions (Firefox/Tools > Add-ons > Extensions) disabled then try to find which extension is causing it by enabling one extension at a time until the problem reappears.

Close and restart Firefox after each change via "Firefox > Exit" (Windows: Firefox/File > Exit; Mac: Firefox > Quit Firefox; Linux: Firefox/File > Quit)

more options

Hi,

Thank you for your answers. hardware acceleration is already deactivated so that isn't the problem. It works in safe mode. I have deactivated all add-ons and it still doesn't work! What now?

more options

Hi psop, could you describe the problem you are experiencing in more detail?

more options

Hi, I have managed to fix it by resetting firefox. Thank you for your help.

more options

This just stopped working in nightly... now at 30.0a1 (2014-02-28)

In addition to not being able to drag icons from the address bar to the personal tool bar, it is no longer possible to re-arrange existing toolbar icons using drag and drop.

Wonder if it is related to syncing?

Beverly Howard

more options

Hi Beverly, if you cannot rearrange items on the Bookmarks Toolbar I think there is a different issue. Possibly a corrupted toolbar data file or an extension interfering or, considering you run Nightly, a bug. You may want to start a new thread.

more options

fwiw, I am relatively certain that the problem with not being able to drag the current url to the bookmakrs toolbar began at the same time that it was no longer possible to drag existing bookmarks.

About a week ago, I spent a lot of time cleaning up my bookmarks... deleting, dragging to rearrange, and adding new bookmarks by dragging from the address field to the bookmarks toolbar.

A few days later, both dragging from the address field _and_ dragging existing bookmarks was no longer possible, so, I feel pretty strongly that the two are related and since I sync mozilla on several machines that a "bounce back" might be an issue.

I just installed the current version and the problem remains. I also tried the "hide" tip and that did not help either.

I am very reluctant to "restore default set" because of the work that has gone into the current setup.

Will not do a "safe mode" restart and see if that helps and report back.

I will start a new thread if necessary, but concerned that it will dilute this quest.

Beverly Howard

more options

Restating with addons disabled did not help.

Beverly Howard

more options

Just closed nightly and fired up firefox... both of the same problems are there as well.

They are obviously both using the same configurations and files as I have not started firefox for several months but it comes up configured the same as nightly with the same bookmarks.

Will scratch around and see if I can deduce anything further.

Beverly Howard

more options

Hi Beverly, adding new replies to a thread that the poster marked solved really is not the best way to get fresh attention... also, in a new thread you can more easily include your configuration information. For example, are you still using the Bookmark Favicon Changer extension?

more options

选择的解决方案

Thanks... didn't see a "closed" flag.

Favicons was one of the first things I uninstalled

wilco

由BevHoward于修改