Search Support

Avoid support scams. We will never ask you to call or text a phone number or share personal information. Please report suspicious activity using the “Report Abuse” option.

Learn More

non-https addressed redirected by something called Sectorlink

more options

Whenever I enter a web address to a non-HTTPS site, the page is redirected by something called Sectorlink that tells me to upload my index page when ready. I don't seem to be able to get around this redirection. It does not happen using Chrome.

In the attached image, I typed "nov" (for novelpost159.org) and the system auto-completed the address and was immediately redirected to Sectorlink. The novelpost159 is not HTTPS and probably never will be, but it is interfered with by Sectorlink. This redirecting (hijacking?) forces me to use the Chrome browser.

Thanks for the help

Whenever I enter a web address to a non-HTTPS site, the page is redirected by something called Sectorlink that tells me to upload my index page when ready. I don't seem to be able to get around this redirection. It does not happen using Chrome. In the attached image, I typed "nov" (for novelpost159.org) and the system auto-completed the address and was immediately redirected to Sectorlink. The novelpost159 is not HTTPS and probably never will be, but it is interfered with by Sectorlink. This redirecting (hijacking?) forces me to use the Chrome browser. Thanks for the help
Ama-screenshot ananyekiwe

All Replies (1)

more options

Hmm, if I try https://novelpost159.org/ I get a certificate error page. But my Firefox doesn't try it automatically, it uses the http address when I click the link in your post.

In case this is a problem with the HTTPS-Only feature, you can make exceptions for sites that do not work properly with HTTPS. This article has more info: HTTPS-Only Mode in Firefox

The way address bar suggestions work, if Firefox has stored the https address in history, it probably takes precedence over the http address. You may need to go into history (Ctrl+Shift+H), find the site, right-click > Delete Page. I wouldn't use the Forget... option at this point.

Helpful?

Buza umbuzo

You must log in to your account to reply to posts. Please start a new question, if you do not have an account yet.